summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2015-10-07 14:33:42 +0200
committerJohannes Dewender2015-10-07 14:44:44 +0200
commitfa2df3290faaffc369285d8c4869e5bebab5aeec (patch)
tree1792eccf35ea1324e2fc8c0969e7c6b1a13178a3 /PKGBUILD
parent148ee39253bf6bbec9c108da2fb8b5f70854b8a2 (diff)
downloadaur-fa2df3290faaffc369285d8c4869e5bebab5aeec.tar.gz
start modifications for mx920
The id and libpng15 patches are not applicable anymore.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55b5367fa92d..154991eb4b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Contributor: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
# Contributor: Stefan Hackl <stef.hackl [at the] gmail [dot] com>
-pkgname=('cnijfilter-mp550')
+pkgname=('cnijfilter-mx920')
_pkgname=cnijfilter
-pkgver=3.20
-pkgrel=11
+pkgver=3.90
+pkgrel=1
_pkgreview=1
-pkgdesc="Canon IJ Printer Driver (For Multifunction MP550 series)"
-url="http://www.canon-europe.com/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MP_series/PIXMA_MP550.aspx"
+pkgdesc="Canon IJ printer driver (multifunction MX920 series)"
+url="http://www.canon-europe.com/support/consumer_Products/products/fax__multifunctionals/inkjet/pixma_mx_series/mx925.aspx"
arch=('i686' 'x86_64')
license=('custom')
@@ -23,29 +24,21 @@ depends_i686=('gtk2' 'libxml2')
makedepends=('autoconf>=2.13' 'automake>=1.6' 'tar' 'make')
depends=("${_pkgname}-common=4.00")
-install=cnijfilter-mp550.install
+install=cnijfilter-mx920.install
-# File size: 6552576 bytes
-source=("http://files.canon-europe.com/files/soft37280/Software/IJ_Linux_Printer_Driver_Source_320.tar"
- "id.patch"
+source=("http://gdlp01.c-wss.com/gds/1/0100005171/01/cnijfilter-source-3.90-1.tar.gz"
"cups.patch"
- "libpng15.patch"
"mychanges.patch")
-sha512sums=('28a82d08d3b8a233b89a17e0e029510fc5b3cede97300eb71a9af03c9a15cca4355167d8706e66c34eb47b6c98202a80d73f80626803c9ff6fa41bdd8c87f235'
- 'b75cdbdadac5fb396458dc9f14529c5e39a4fa47f97cd6a21a69b0dbac73f1b8dd90780068f6a348fcfb15939d0866dde1a1cf1ff7faaf0c443d2205a242ccd5'
- 'f1f8cc44d7892eb50b44e0fe9d5be877fa5d8f8783aedf494d739eee20c147befac4f4776959f42cdb9cfd9f766522635fc2aae2626fdaf0c4465226a66dcc0e'
- '0d8310867f45721150a870170172d3a0688bfba0267f627a630c105ff965d31f25dbcc31d3795874325bcb8eaeee395bf32b0648a743ff663dea6f977ab9070e'
- '807a2f726b5fb0f383118fc6c60449bd37f3a68f788a0ba2e3643f054f592fb886298c397b190280ef565cba2fe57f943abdbf86e8a4890172aaf716984cb70f')
+sha512sums=('9ec303dc7209f5534a20e533fc18ec810603f4515655ce67f28f0f35d521185181351fd866d2191939eb02c783b168f637e18888a4e6a1eacc9e93b1b656ebcb'
+ 'af0de981c5610f4001b5ab4d6fb042f48879995c1e1434fa3819e02d2030ceaf35b183f8cbab530435af6d452bb88c23e522c51d20e9cb5c81a7ff6a4c2df915'
+ '1cf54862db74f928a3a1ad0316b9940b843dbc4cae95bbb3d93ab317d248788cf844103bc006b4670c27b0f13952301b5907476a6c7d13ebb0cb5c0a942d6182')
prepare() {
cd ${srcdir}
tar xzf ${_pkgname}-source-${pkgver}-${_pkgreview}.tar.gz
cd ${srcdir}/${_pkgname}-source-${pkgver}-${_pkgreview}
- patch -p1 -i ${srcdir}/id.patch
patch -p1 -i ${srcdir}/cups.patch
- patch -p1 -i ${srcdir}/libpng15.patch
-
patch -p1 -i ${srcdir}/mychanges.patch
}
@@ -53,12 +46,12 @@ build() {
cd ${srcdir}/${_pkgname}-source-${pkgver}-${_pkgreview}
export CC="gcc -m32"
- make mp550
+ make mx920
}
package() {
cd ${srcdir}/cnijfilter-source-${pkgver}-${_pkgreview}
- make PACKAGEDIR=${pkgdir} installmp550
+ make PACKAGEDIR=${pkgdir} installmx920
install -d ${pkgdir}/usr/lib32/bjlib
install -m 644 359/database/* ${pkgdir}/usr/lib32/bjlib/