summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-06-01 11:15:43 -0600
committerMark Wagie2020-06-01 11:15:43 -0600
commit350933be84fe5f44fd27bbe5a365e44ed38a50b0 (patch)
tree7e8fb23da488c5a673c1475b2775ca5b1cf6cb5a /PKGBUILD
parent578e99e6524ea671a10bb4e6b72c75260c1be256 (diff)
downloadaur-350933be84fe5f44fd27bbe5a365e44ed38a50b0.tar.gz
update build flags according to guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 970ff168cdd6..6512baec1ffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=cod
pkgver=0.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="A completion daemon for bash/zsh"
arch=('any')
url="https://github.com/dim-an/cod"
license=('Apache-2.0')
-makedepends=('go-pie')
+makedepends=('go')
optdepends=('bash-completion')
source=("$pkgname-$pkgver.tar.gz::https://github.com/dim-an/cod/archive/v$pkgver.tar.gz")
sha256sums=('6f773358f363141dcd1bbdffaaa5dea0a40ae7a84d5fc55fd453302de8493c20')
@@ -15,8 +15,11 @@ build() {
cd "$pkgname-$pkgver"
go build \
-trimpath \
- -ldflags "-extldflags $LDFLAGS" \
- -o $pkgname .
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-extldflags \"${LDFLAGS}\"" \
+ -o "$pkgname" .
}
package() {