summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hansen2018-04-14 10:22:57 -0700
committerMichael Hansen2018-04-14 10:22:57 -0700
commit27453e7c4ca543b65e37e103ebbce4023b911f87 (patch)
treefc98cf0a5be7159a279344bcc8e420221391e62f /PKGBUILD
parent4860d2b607eb0eced2857f2ec8c91e7b13eac5e7 (diff)
downloadaur-27453e7c4ca543b65e37e103ebbce4023b911f87.tar.gz
Update message to show both systemd and non-systemd file limit configs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dceb0aa7ec5c..94f678f9a3b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -66,9 +66,13 @@ build() {
echo
echo "*** NOTE: If the build failed due to running out of file handles (EMFILE),"
echo "*** you will need to raise your max open file limit."
- echo "*** This can be done by setting a higher limit in /etc/security/limits.conf,"
- echo "*** rebooting (or logging out and back in), and then running"
- echo "*** 'ulimit -n 10000' (or higher) before re-attempting to build this package."
+ echo "*** This can be done by:"
+ echo "*** 1) Set a higher 'nofile' limit (at least 10000) in either"
+ echo "*** /etc/systemd/system.conf.d/limits.conf (for systemd systems)"
+ echo "*** /etc/security/limits.conf (for non-systemd systems)"
+ echo "*** 2) Reboot (or log out and back in)"
+ echo "*** 3) Run 'ulimit -n' and ensure the value set above is shown before"
+ echo "*** re-attempting to build this package."
echo
exit 1
fi