summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hansen2016-11-02 15:15:55 -0700
committerMichael Hansen2016-11-02 15:15:55 -0700
commita83dd07b40bac880c7406e47808510aedddd7210 (patch)
tree303a19029f80133f07ad2a441a4d3e8d7d3c906c /PKGBUILD
parentcc14c24cc4ad3db1903623429710d576758499d7 (diff)
downloadaur-a83dd07b40bac880c7406e47808510aedddd7210.tar.gz
Update to 1.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aadb2f2b7d1b..a47812661c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
pkgname=visual-studio-code-oss
pkgdesc='Visual Studio Code for Linux, Open Source version'
-pkgver=1.6.1
-pkgrel=3
-_commit=9e4e44c19e393803e2b05fe2323cf4ed7e36880e
+pkgver=1.7.0
+pkgrel=1
+_commit=9e7d70052908b633e0d4f71e70b26714bd1d2f10
arch=('i686' 'x86_64')
url='https://code.visualstudio.com/'
license=('MIT')
@@ -19,11 +19,9 @@ conflicts=('vscode-oss')
provides=('vscode-oss')
source=("${pkgver}-${pkgrel}.tar.gz::https://github.com/Microsoft/vscode/archive/${_commit}.tar.gz"
- "${pkgname}.desktop"
- 'rebuild-monaco.patch.gz')
-sha1sums=('d2b827fbc7aa8b54343f6cda452fb74142e1993a'
- '9c4176c4d99103736df6746ca174b5026bd57e6b'
- '0f4f62ec0a9ee4123198180bb9494ea87170eb1b')
+ "${pkgname}.desktop")
+sha1sums=('73f39dad26a78caeaa231b88e361145ccb75218f'
+ '9c4176c4d99103736df6746ca174b5026bd57e6b')
if (( VSCODE_NONFREE )); then
source+=('product_json.patch')
@@ -54,12 +52,6 @@ prepare() {
sed -e "s/@COMMIT@/$_commit/" -e "s/@DATE@/$_datestamp/" \
-i product.json
fi
-
- # gulp now generates monaco.d.ts without preceeding whitespace, which the
- # build detects as being an uncommitted change :(. This patch doesn't
- # actually change any of the code, it just makes the whitespace match so
- # the build system doesn't complain about it.
- patch -p1 -i "${srcdir}/rebuild-monaco.patch"
}
build() {