summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hansen2016-11-03 09:44:27 -0700
committerMichael Hansen2016-11-03 09:44:27 -0700
commitd833218fd24e7ac4ab9abfab018d2caf76b5fcee (patch)
treeb03cdac0f1ad8a3812cc9bf863f6f66eac3d09ad /PKGBUILD
parenta83dd07b40bac880c7406e47808510aedddd7210 (diff)
downloadaur-d833218fd24e7ac4ab9abfab018d2caf76b5fcee.tar.gz
Revert "Update to 1.7.0".
It has been rolled back by Microsoft due to overloading the npmjs.org service: https://code.visualstudio.com/updates#_17-rollback This reverts commit a83dd07b40bac880c7406e47808510aedddd7210.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a47812661c1d..aadb2f2b7d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
pkgname=visual-studio-code-oss
pkgdesc='Visual Studio Code for Linux, Open Source version'
-pkgver=1.7.0
-pkgrel=1
-_commit=9e7d70052908b633e0d4f71e70b26714bd1d2f10
+pkgver=1.6.1
+pkgrel=3
+_commit=9e4e44c19e393803e2b05fe2323cf4ed7e36880e
arch=('i686' 'x86_64')
url='https://code.visualstudio.com/'
license=('MIT')
@@ -19,9 +19,11 @@ conflicts=('vscode-oss')
provides=('vscode-oss')
source=("${pkgver}-${pkgrel}.tar.gz::https://github.com/Microsoft/vscode/archive/${_commit}.tar.gz"
- "${pkgname}.desktop")
-sha1sums=('73f39dad26a78caeaa231b88e361145ccb75218f'
- '9c4176c4d99103736df6746ca174b5026bd57e6b')
+ "${pkgname}.desktop"
+ 'rebuild-monaco.patch.gz')
+sha1sums=('d2b827fbc7aa8b54343f6cda452fb74142e1993a'
+ '9c4176c4d99103736df6746ca174b5026bd57e6b'
+ '0f4f62ec0a9ee4123198180bb9494ea87170eb1b')
if (( VSCODE_NONFREE )); then
source+=('product_json.patch')
@@ -52,6 +54,12 @@ prepare() {
sed -e "s/@COMMIT@/$_commit/" -e "s/@DATE@/$_datestamp/" \
-i product.json
fi
+
+ # gulp now generates monaco.d.ts without preceeding whitespace, which the
+ # build detects as being an uncommitted change :(. This patch doesn't
+ # actually change any of the code, it just makes the whitespace match so
+ # the build system doesn't complain about it.
+ patch -p1 -i "${srcdir}/rebuild-monaco.patch"
}
build() {