summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-06-02 13:25:31 -0400
committeracxz2020-06-02 13:25:31 -0400
commitfac33ac33dfb06a16f4226e1b7e00e8fdffd0cf4 (patch)
tree95f6b404dcd4795220a2655609d433956892a321 /PKGBUILD
parent67d2805027d442bb33160f6892fc82e21be6bf79 (diff)
downloadaur-fac33ac33dfb06a16f4226e1b7e00e8fdffd0cf4.tar.gz
patch exponent issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e6a09a8d735..5824ac34ee87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Contributor: Max Devaine <max@devaine.cz>
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Max Devaine <max@devaine.cz>
+
pkgname=code-eli-git
-pkgver=r821.f9ff74f
-pkgrel=3
+pkgver=r826.b6e1bd3
+pkgrel=1
pkgdesc='Collection of C++ libraries that provide a variety of functionalities.'
arch=('i686' 'x86_64')
url='https://github.com/ramcdona/Code-Eli'
@@ -13,15 +14,20 @@ optdepends=('cpptest: unit tests'
makedepends=('cmake' 'git')
_name=Code-Eli
provides=('code-eli')
-source=("git+https://github.com/ramcdona/Code-Eli.git")
-md5sums=('SKIP')
+source=("git+https://github.com/ramcdona/Code-Eli.git"
+ "exponent.patch::https://patch-diff.githubusercontent.com/raw/ramcdona/Code-Eli/pull/8.patch")
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "$_name"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-_buildtype="Release"
+prepare() {
+ cd "${srcdir}/${_name}"
+ patch --forward --strip=1 --input="${srcdir}/exponent.patch"
+}
build() {
@@ -29,28 +35,20 @@ build() {
mkdir -p "${srcdir}/${_name}/build"
cd "${srcdir}/${_name}/build"
- msg "Starting CMake (build type: ${_buildtype})"
-
cmake .. \
- -DCMAKE_BUILD_TYPE=${_buildtype} \
-DCMAKE_INSTALL_PREFIX='/usr'
- msg "Building the project"
make
-
}
package() {
cd "${srcdir}/${_name}"
- msg "Installing files"
-
mkdir -p "${pkgdir}/usr/include/eli"
# include
cp -r include/eli/* ${pkgdir}/usr/include/eli
cd "${srcdir}/${_name}/build"
cp -r include/eli/* ${pkgdir}/usr/include/eli
-
}