summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2017-03-05 04:23:54 -0500
committerChris Severance2017-03-05 04:23:54 -0500
commitc8e78d5ef9ae7b3d64a10dedbce20a5a5b8df4e9 (patch)
treed208e2940455185f709fcf1542d1baceef47ca16 /PKGBUILD
parentd84bbea787c8460ba57e5a86961bbdc23a4f0283 (diff)
downloadaur-c8e78d5ef9ae7b3d64a10dedbce20a5a5b8df4e9.tar.gz
Add dependency webkitgtk2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5b84be545ab..500a19d5243f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
set -u
pkgname='codeblocks-svn'
-pkgver=10982
+pkgver=11023
pkgrel=1
pkgdesc='An open source and cross-platform C/C++ IDE'
arch=('i686' 'x86_64')
url='http://www.codeblocks.org'
license=('GPL')
-depends=('wxgtk' 'valgrind' 'bzip2' 'hicolor-icon-theme' 'gamin' 'hunspell')
+depends=('wxgtk' 'valgrind' 'bzip2' 'hicolor-icon-theme' 'gamin' 'hunspell' 'webkitgtk2')
makedepends=('boost' 'subversion' 'zip')
provides=("codeblocks=${pkgver}")
conflicts=('codeblocks' 'codeblocks-svn-noplugins')
@@ -31,9 +31,13 @@ pkgver() {
build() {
set -u
cd 'codeblocks-svn'
- ./bootstrap
- WX_CONFIG_PATH='/usr/bin/wx-config' \
- ./configure --prefix='/usr' --with-contrib-plugins='all'
+ if [ ! -s 'configure' ]; then # compatible with makepkg -e
+ ./bootstrap
+ fi
+ if [ ! -s 'Makefile' ]; then
+ WX_CONFIG_PATH='/usr/bin/wx-config' \
+ ./configure --prefix='/usr' --with-contrib-plugins='all'
+ fi
local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
make -s -j"${_nproc}"
set +u