summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotreblan2020-09-17 18:45:21 -0500
committerotreblan2020-09-17 18:45:21 -0500
commit858adcc11ddbe55733a30bb47589498be78738f5 (patch)
tree2951736809106f73f673ea44a1f4124a8c38d301 /PKGBUILD
downloadaur-858adcc11ddbe55733a30bb47589498be78738f5.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9027723aefaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Otreblan <otreblain@gmail.com>
+
+pkgname=codechef-cli
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="CodeChef Command Line Client."
+arch=('any')
+url="https://github.com/sk364/codechef-cli"
+license=('GPL3')
+groups=()
+depends=("python-requests-html")
+makedepends=("python-setuptools")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+noextract=()
+sha256sums=('87763b117ae1970d31920a86646413713ea6fc09eddc4fca8a76ef8c84d379f9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}