summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Conroy-Finn2018-04-10 12:32:45 +0100
committerJames Conroy-Finn2018-04-10 12:32:45 +0100
commitfd7df2499292ce1b08c11601554e7aeb28ce7be1 (patch)
treee9562056069e7f5da958b3387eb21f52d43325f3 /PKGBUILD
downloadaur-fd7df2499292ce1b08c11601554e7aeb28ce7be1.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd2ca4133b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: JUXT <info@juxt.pro>
+# Contributor: James Conroy-Finn <james@invetica.co.uk>
+pkgname=codedeploy-agent
+pkgver=1.0_1.1458
+pkgrel=1
+pkgdesc="AWS CodeDeploy is a deployment service that enables developers to automate the deployment of applications to instances and to update the applications as required."
+arch=('i686' 'x86_64')
+url="https://aws.amazon.com/documentation/codedeploy/"
+license=('APACHE')
+groups=()
+depends=('ruby')
+source=(https://aws-codedeploy-eu-west-1.s3-eu-west-1.amazonaws.com/releases/${pkgname}_${pkgver//_/-}_all.deb)
+md5sums=('78540a9e2fa0f79820a3b2b7ca998e45')
+noextract=()
+
+prepare() {
+ cd "$srcdir"
+ tar -xf data.tar.gz
+}
+
+package() {
+ cd "$srcdir"
+
+ install -dm755 "$pkgdir"/opt/
+ cp -R "${srcdir}"/opt/codedeploy-agent "${pkgdir}/opt/"
+
+ install -Dm744 \
+ "$srcdir"/etc/codedeploy-agent/conf/codedeployagent.yml \
+ "$pkgdir"/etc/codedeploy-agent/conf/codedeployagent.yml
+
+ install -Dm744 \
+ "$srcdir"/etc/init.d/codedeploy-agent.service \
+ "$pkgdir"/usr/lib/systemd/system/codedeploy-agent.service
+}
+
+# vim:set ts=2 sw=2 et: