summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMahor2022-07-26 10:14:08 +0430
committerMahor2022-07-26 10:14:08 +0430
commitb62af8f909217d6dea54bbf0a2747c73b3c780c3 (patch)
treed1be47edc80a4564723e8abfa2e14edeb758366a /PKGBUILD
parente7f6aaa230e3db83d40832887ae28da22738c49c (diff)
downloadaur-b62af8f909217d6dea54bbf0a2747c73b3c780c3.tar.gz
Bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 40 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce571cfd4146..f304e5171deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,50 @@
# Maintainer: bageljr <bageljr 897 at protonmail dot com>
-# Contributor: dmitmel
+# Contributor: dmitmel <dmytro dot meleshko at gmail dot com>
+# Maintainer: Mahor1221 <mahor1221 at pm dot me>
+
pkgname=codelldb
_reponame=vscode-lldb
-pkgdesc="A native debugger extension for VSCode based on LLDB. Also known as vscode-lldb (NOT lldb-vscode)"
-pkgver=1.7.2
+pkgver=1.7.3
pkgrel=1
+pkgdesc="A native debugger extension for VSCode based on LLDB. Also known as vscode-lldb (NOT lldb-vscode)"
+arch=("x86_64" "arm7h" "aarch64")
url="https://github.com/vadimcn/$_reponame"
-arch=("x86_64" "aarch64" "arm7h")
-license=("custom:MIT")
-options=(!debug strip) #Debug package is broken
-source=("$_reponame-$pkgver.tar.gz::https://github.com/vadimcn/$_reponame/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=("1258815e76429ae4ef17b1b8f0ac62e2d64e1f64283a1ffb38e6ab276b375558")
+license=("MIT")
+provides=("$pkgname" "$_reponame")
depends=(lldb)
makedepends=(cmake cargo npm python)
-build() {
- export RUSTUP_TOOLCHAIN=stable
- export CFLAGS="-mtune=generic -O2 -pipe -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security"
- # Doesn't build with -fno-plt
- cd "$_reponame-$pkgver"
- cmake -B build -DLLDB_PACKAGE=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
- cmake --build build --target codelldb
+options=(!debug strip) #Debug package is broken
+source=("$_reponame-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('699d3e7041a72d5ab5bd2004906223a4ced4ec316fa4d76fdab8b5e8ee83c32e')
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CFLAGS="-mtune=generic -O2 -pipe -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security"
+ # Doesn't build with -fno-plt
+ cd "$_reponame-$pkgver"
+ cmake -B build -DLLDB_PACKAGE=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
+ cmake --build build --target codelldb
}
+
package() {
- local reset_shopt="$(shopt -p globstar)"
- shopt -s globstar
-
- cd "$_reponame-$pkgver"
- local _lib_dir="$pkgdir/usr/lib/codelldb"
-
- # <https://github.com/vadimcn/vscode-lldb/blob/v1.7.0/CMakeLists.txt#L173-L186>
- install -Dm644 -t "$_lib_dir" build/platform.ok
- install -Dm755 -t "$_lib_dir"/adapter build/adapter/{codelldb,*.so}
- install -Dm644 -t "$_lib_dir"/adapter build/adapter/*.py
- install -Dm644 -t "$_lib_dir"/formatters build/formatters/**/*.py
-
- install -d "$_lib_dir"/lldb
- ln -s -t "$_lib_dir"/lldb /usr/{bin,lib}
-
- install -d "$pkgdir"/usr/bin
- ln -s -t "$pkgdir"/usr/bin "$_lib_dir"/adapter/codelldb
-
- install -Dm644 -t "$pkgdir"/usr/share/licenses/"$pkgname" LICENSE
- eval "$reset_shopt"
+ local reset_shopt="$(shopt -p globstar)"
+ shopt -s globstar
+
+ cd "$_reponame-$pkgver"
+ local _lib_dir="$pkgdir/usr/lib/$pkgname"
+
+ # <https://github.com/vadimcn/vscode-lldb/blob/v1.7.0/CMakeLists.txt#L173-L186>
+ install -Dm644 -t "$_lib_dir" build/platform.ok
+ install -Dm755 -t "$_lib_dir"/adapter build/adapter/{codelldb,*.so}
+ install -Dm644 -t "$_lib_dir"/adapter build/adapter/*.py
+ install -Dm644 -t "$_lib_dir"/formatters build/formatters/**/*.py
+
+ install -d "$_lib_dir"/lldb
+ ln -s -t "$_lib_dir"/lldb /usr/{bin,lib}
+
+ install -d "$pkgdir"/usr/bin
+ ln -s -t "$pkgdir"/usr/bin /usr/lib/"$pkgname"/adapter/codelldb
+
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/"$pkgname" LICENSE
+ eval "$reset_shopt"
}