summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 03:03:37 +0300
committerDimitris Kiziridis2020-07-17 03:03:37 +0300
commit80fd82d308d7a3a26eb93f12f5f5d40632719c29 (patch)
tree946794771e65cca1f22279ed86c9526860c775d9 /PKGBUILD
downloadaur-80fd82d308d7a3a26eb93f12f5f5d40632719c29.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7be3cf79f7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=codereview
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A Git GUI tool to perform code review (Diff Viewer) written in Python3 and Qt5'
+arch=('x86_64')
+url="http://fabricesalvaire.github.io/CodeReview"
+license=('GPL3')
+depends=('python-pyqt5'
+ 'python-pygments'
+ 'python-yaml'
+ 'python-pygit2')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/FabriceSalvaire/CodeReview/archive/v${pkgver}.tar.gz")
+sha256sums=('e490a0fe080c57fdf56f272d06cf70b37f91e9a05147595a1f596d98fd8ce0d2')
+
+prepare() {
+ cd "CodeReview-${pkgver}"
+ sed -i "50s|.*||" CodeReview/Tools/Platform.py
+}
+
+build() {
+ cd "CodeReview-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "CodeReview-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+} \ No newline at end of file