summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-08-24 16:26:22 +0300
committerAdrian Perez de Castro2022-08-24 16:26:22 +0300
commit2076a80be389d80e85d53db3804074b5263cf3c0 (patch)
tree5154763fd50f9be2298390643731069e433fa13a /PKGBUILD
parent3e3b0686f686450b76d9ac8d6d7a01e5cbab5572 (diff)
downloadaur-2076a80be389d80e85d53db3804074b5263cf3c0.tar.gz
Bump to version 0.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b3af6d5397a..d8473ed2d898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='WPE launcher and webapp container'
pkgname=cog
-pkgver=0.12.4
+pkgver=0.14.0
pkgrel=1
url=https://github.com/Igalia/cog
arch=(i686 x86_64 aarch64 armv7l armv7h)
groups=(wpe)
conflicts=(cog-git)
-depends=('wpewebkit>=2.30.0' 'wpebackend-fdo>=1.8.0' libinput)
-makedepends=(cmake wayland-protocols libxcb libxkbcommon-x11 gtk4)
+depends=('wpewebkit>=2.36.0' 'wpebackend-fdo>=1.10.0' libinput)
+makedepends=(cmake wayland-protocols libxcb libxkbcommon-x11 gtk4 weston)
optdepends=('libxcb: x11 platform support'
'libxkbcommon-x11: x11 platform support'
'gtk4: gtk4 platform support')
@@ -16,11 +16,12 @@ license=(custom:MIT)
source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"
"https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz.asc")
validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
-md5sums=(cdb8acdc3acc9b5082e7db9c279155c3 SKIP)
-sha1sums=(600b30efadf55bf94ea5062a0a1b2ea0b74053e5 SKIP)
-sha256sums=(9983c621c8e14fca3792ff566cb6b86d6a1f17446eb4c083af4a5a749112982f SKIP)
+md5sums=(2352aaba1a4ff31b1d1fb559c4941a01 SKIP)
+sha1sums=(2da37ea6c25e45425aa80de4a129484ee226dd96 SKIP)
+sha256sums=(e23936f1ce350ea5ea6fa0709b63d34776b05709388aed9c6cf3fdc41299de9f SKIP)
build () {
+ CFLAGS="${CFLAGS} $(pkg-config libdrm --cflags)" \
cmake -H"${pkgname}-${pkgver}" -Bbuild \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -33,7 +34,7 @@ build () {
-DCOG_PLATFORM_HEADLESS=ON \
-DCOG_BUILD_PROGRAMS=ON \
-DINSTALL_MAN_PAGES=ON \
- -DCOG_WESTON_DIRECT_DISPLAY=OFF # Needs libweston-9-protocols
+ -DCOG_WESTON_DIRECT_DISPLAY=ON
cmake --build build
}