summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2022-11-14 21:30:03 +0200
committerAdrian Perez de Castro2022-11-14 21:30:03 +0200
commit658e80c5d307f3f46dbc088890dfc31f60a0c049 (patch)
tree46f912a1976fc96b11246065e22a5b8ba0bb3f9d /PKGBUILD
parent2076a80be389d80e85d53db3804074b5263cf3c0 (diff)
downloadaur-658e80c5d307f3f46dbc088890dfc31f60a0c049.tar.gz
Bump to version 0.16.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 17 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8473ed2d898..9e7496f7214f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='WPE launcher and webapp container'
pkgname=cog
-pkgver=0.14.0
+pkgver=0.16.1
pkgrel=1
url=https://github.com/Igalia/cog
arch=(i686 x86_64 aarch64 armv7l armv7h)
groups=(wpe)
conflicts=(cog-git)
depends=('wpewebkit>=2.36.0' 'wpebackend-fdo>=1.10.0' libinput)
-makedepends=(cmake wayland-protocols libxcb libxkbcommon-x11 gtk4 weston)
+makedepends=(meson wayland-protocols libxcb libxkbcommon-x11 gtk4 weston)
optdepends=('libxcb: x11 platform support'
'libxkbcommon-x11: x11 platform support'
'gtk4: gtk4 platform support')
@@ -16,30 +16,26 @@ license=(custom:MIT)
source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"
"https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz.asc")
validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
-md5sums=(2352aaba1a4ff31b1d1fb559c4941a01 SKIP)
-sha1sums=(2da37ea6c25e45425aa80de4a129484ee226dd96 SKIP)
-sha256sums=(e23936f1ce350ea5ea6fa0709b63d34776b05709388aed9c6cf3fdc41299de9f SKIP)
+md5sums=(1489740db6b4ea568578035c30b8b2f4 SKIP)
+sha1sums=(1235203085e7ccd8fc76eab6bdfcdb2e3ae38ea9 SKIP)
+sha256sums=(37c5f14123b8dcf077839f6c60f0d721d2a91bb37829e796f420126e6b0d38b5 SKIP)
build () {
- CFLAGS="${CFLAGS} $(pkg-config libdrm --cflags)" \
- cmake -H"${pkgname}-${pkgver}" -Bbuild \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DUSE_SOUP2=OFF \
- -DCOG_PLATFORM_WL=ON \
- -DCOG_PLATFORM_DRM=ON \
- -DCOG_PLATFORM_X11=ON \
- -DCOG_PLATFORM_GTK4=ON \
- -DCOG_PLATFORM_HEADLESS=ON \
- -DCOG_BUILD_PROGRAMS=ON \
- -DINSTALL_MAN_PAGES=ON \
- -DCOG_WESTON_DIRECT_DISPLAY=ON
- cmake --build build
+ rm -rf _build
+ arch-meson \
+ -D documentation=false \
+ -D manpages=true \
+ -D platforms=drm,gtk4,headless,wayland,x11 \
+ -D programs=true \
+ -D soup2=disabled \
+ -D wayland_weston_content_protection=true \
+ -D wayland_weston_direct_display=true \
+ _build "${pkgname}-${pkgver}"
+ meson compile -C _build
}
package () {
- DESTDIR="${pkgdir}" cmake --build build --target install
+ meson install -C _build --destdir "${pkgdir}"
install -Dm644 "${pkgname}-${pkgver}/COPYING" \
"${pkgdir}/usr/share/licenses/${pkgname}/COPYING"