summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-06-03 00:31:22 +0300
committerAdrian Perez de Castro2023-06-03 00:31:22 +0300
commitb6ee2b9f87c701fbdc9ad1f494cf83f22204a975 (patch)
tree6164c610f5a3370a02f1a5b07cfb04c2fb9ad965 /PKGBUILD
parent658e80c5d307f3f46dbc088890dfc31f60a0c049 (diff)
downloadaur-b6ee2b9f87c701fbdc9ad1f494cf83f22204a975.tar.gz
Bump to version 0.18.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e7496f7214f..40185bfa71ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='WPE launcher and webapp container'
pkgname=cog
-pkgver=0.16.1
+pkgver=0.18.0
pkgrel=1
url=https://github.com/Igalia/cog
arch=(i686 x86_64 aarch64 armv7l armv7h)
groups=(wpe)
conflicts=(cog-git)
-depends=('wpewebkit>=2.36.0' 'wpebackend-fdo>=1.10.0' libinput)
+depends=('wpewebkit>=2.36.0' 'wpebackend-fdo>=1.10.0' libinput libmanette)
makedepends=(meson wayland-protocols libxcb libxkbcommon-x11 gtk4 weston)
optdepends=('libxcb: x11 platform support'
'libxkbcommon-x11: x11 platform support'
@@ -16,9 +16,9 @@ license=(custom:MIT)
source=("https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz"
"https://wpewebkit.org/releases/${pkgname}-${pkgver}.tar.xz.asc")
validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B')
-md5sums=(1489740db6b4ea568578035c30b8b2f4 SKIP)
-sha1sums=(1235203085e7ccd8fc76eab6bdfcdb2e3ae38ea9 SKIP)
-sha256sums=(37c5f14123b8dcf077839f6c60f0d721d2a91bb37829e796f420126e6b0d38b5 SKIP)
+md5sums=('9521458c72322e1b2e39e8b1cca93d24' 'SKIP')
+sha1sums=('73ec1684c31de7247ecbd5e852c16cf88416bedd' 'SKIP')
+sha256sums=('410bf70f9aa3812db72d75c25cefee421efa0391ab03dc3c37299dfaa388f4fd' 'SKIP')
build () {
rm -rf _build
@@ -27,9 +27,9 @@ build () {
-D manpages=true \
-D platforms=drm,gtk4,headless,wayland,x11 \
-D programs=true \
- -D soup2=disabled \
-D wayland_weston_content_protection=true \
-D wayland_weston_direct_display=true \
+ -D wpe_api=1.1 \
_build "${pkgname}-${pkgver}"
meson compile -C _build
}