summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Balula2021-05-10 12:46:42 +0200
committerSamuel Balula2021-05-10 12:46:42 +0200
commit0a221e18f4550c7420a8be5cd724b1f794c4a86e (patch)
tree4ff8ff9af9e8813193d182bbe208d8881490480b /PKGBUILD
downloadaur-0a221e18f4550c7420a8be5cd724b1f794c4a86e.tar.gz
initial package upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d05483f8b1c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Samuel Balula sbalula@ethz.ch
+# Download the source from http://www.hsl.rl.ac.uk/ and place it in the folder, replacing the empty placeholder file
+
+pkgname=coin-or-hsl
+_pkgname=coinhsl
+pkgrel=1
+pkgver=2019.05.21
+pkgdesc="HSL Mathematical Software Library. Including solvers for sparse linear systems of equations and sparse eigenvalue problems. Compiled with coin-or-tools, supports Ipopt."
+arch=('i686' 'x86_64')
+url="http://www.hsl.rl.ac.uk/"
+makedepends=('gcc' 'metis')
+depends=()
+optdepends=('openmp' 'coin-or-ipopt')
+source=("ThirdParty-HSL::git+https://github.com/coin-or-tools/ThirdParty-HSL.git" "manual://${_pkgname}-${pkgver}.tar.gz")
+sha256sums=("SKIP" "95ce1160f0b013151a3e25d40337775c760a8f3a79d801a1d190598bf4e4c0c3")
+
+build() {
+ cd $srcdir/ThirdParty-HSL
+ ln -sf ../${_pkgname}-${pkgver} coinhsl
+ ./configure
+ make DESTDIR=$pkgdir
+}
+
+package ()
+{
+ cd $srcdir/ThirdParty-HSL
+ make DESTDIR=$pkgdir install
+
+ #For Ipopt:
+ ln -rs $pkgdir/usr/local/lib/libcoinhsl.so $pkgdir/usr/local/lib/libhsl.so
+}