summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-12-22 01:40:22 -0500
committeracxz2019-12-22 01:40:22 -0500
commitf640c37a630747064162e41709fe552c8d60dd06 (patch)
tree90c05c74f0fd55753038672c6219cae51003255b /PKGBUILD
downloadaur-color-scripts-git.tar.gz
create color-scripts-git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..714c131fd41d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=color-scripts-git
+pkgver=r59.299a816
+pkgrel=1
+pkgdesc="User contributed color scripts"
+url="https://git.io/color.sh"
+arch=(any)
+license=('None')
+makedepends=(git)
+provides=('color-scripts')
+conflicts=('color-scripts')
+_name=Color-Scripts
+source=("git+https://github.com/stark/Color-Scripts.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+
+ msg "Nothing to build"
+
+}
+
+package() {
+
+ cd ${srcdir}/${_name}
+
+ msg "Installing Files"
+
+ # color-scripts
+ mkdir -p ${pkgdir}/usr/bin
+ # Don't want a conflict with pacman :)
+ mv color-scripts/pacman color-scripts/pacman-colors
+ cp color-scripts/* ${pkgdir}/usr/bin
+
+ # preview
+ mkdir -p ${pkgdir}/usr/share/color-scripts
+ cp -r preview ${pkgdir}/usr/share/color-scripts
+
+ # test-color-support
+ cp test-color-support/* ${pkgdir}/usr/bin
+
+ # README.md
+ cp README.md ${pkgdir}/usr/share/color-scripts
+
+}