summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkkenoth2016-05-20 00:48:57 +0200
committerAkkenoth2016-05-20 00:48:57 +0200
commit36f12eb202bb8615a559d8cb206f513519b10af7 (patch)
treefa0b0bf500d2de7ea6b7dae569eb731f5c8e6e57 /PKGBUILD
downloadaur-colortail-git.tar.gz
Colortail-git first AUR release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0f84a943b0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Akkenoth <akkenoth at gmail dot com>
+
+pkgname=colortail-git
+pkgver=20160223.3b76525e
+_gitver=3b7625ebaf3d80fa6a5951bdac00e16fcccf9dd9
+pkgrel=1
+pkgdesc="Colortail works like tail but can optionally read one or more config files where it's specified which patterns results in which colors."
+arch=("i686" "x86_64")
+url="https://github.com/joakim666/colortail"
+license=("GPL")
+groups=()
+depends=()
+makedepends=("git")
+provides=("colortail")
+conflicts=("colortail")
+replaces=("colortail")
+backup=()
+options=()
+install=
+source=("https://github.com/joakim666/colortail/archive/${_gitver}.zip")
+noextract=()
+md5sums=("3d2af1106435de1fcd47ead4ce76a53d")
+
+build() {
+ cd "colortail-${_gitver}"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "colortail-${_gitver}"
+ make DESTDIR="$pkgdir/" install
+}