summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorasukaminato2023-05-24 17:52:57 +0900
committerasukaminato2023-05-24 17:52:57 +0900
commit65c842f93e4d1cf1099ff7168354b14804b069b3 (patch)
treecfe80f8d94a5c49dd5e98565d9992fc02411568f /PKGBUILD
downloadaur-65c842f93e4d1cf1099ff7168354b14804b069b3.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b59876487dd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=com.microsoft.word.deepin
+pkgver=2007deepin1
+pkgrel=1
+epoch=
+pkgdesc="Microsoft Word on Deepin Wine"
+arch=(x86_64)
+url="https://www.microsoft.com/en/microsoft-365/previous-versions/download-office-2007"
+license=('custom')
+groups=()
+depends=(
+ deepin-wine5
+ glib2 at-spi2-core libx11 fontconfig xdg-utils gdk-pixbuf2 pango gtk2 glibc bash cairo freetype2)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://com-store-packages.uniontech.com/appstore/pool/appstore/c/$pkgname/${pkgname}_${pkgver}_i386.deb"
+)
+noextract=()
+sha256sums=('3ea0c26e380f5f31d6cc9f4386784465942de83ce614f2d22a6eb819d5d8d5ce')
+validpgpkeys=()
+
+package() {
+ tar -xvpf data.tar.* -C $pkgdir
+ install -d "$pkgdir"/usr/share/icons
+ find "$pkgdir" -name "*.desktop" -exec install -Dm644 {} -t "$pkgdir"/usr/share/applications/ \;
+ find "$pkgdir" -name hicolor -type d -exec cp -av {} "$pkgdir"/usr/share/icons/ \;
+ echo "run /opt/apps/com.microsoft.word.deepin/files/run.sh to launch the app"
+}