summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgato_lento2017-04-08 12:41:02 -0500
committergato_lento2017-04-08 12:41:02 -0500
commit43539af96ecc3c4b53ea9ffc988b7f046a2ec0b2 (patch)
treed93b26b0d4a7658b90dcd037cb8dc0a4e355da74 /PKGBUILD
downloadaur-43539af96ecc3c4b53ea9ffc988b7f046a2ec0b2.tar.gz
1st commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcf97137275c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: gato_lento <vukk.euob at gmail>
+pkgname=combustion
+pkgver=0.5.1
+pkgrel=1
+pkgdesc='Sleek, modern web interface for Transmission'
+arch=('any')
+url='https://github.com/Secretmapper/combustion'
+license=('MIT')
+depends=('transmission-cli')
+
+source=(
+ "https://github.com/Secretmapper/$pkgname/archive/release.zip"
+ "LICENSE"
+ "combustion.sh"
+)
+
+sha1sums=(
+ 3324c2a081d3a5c6ba3c192e5ef3e324910ad369
+ ee69e0bf9099a1ff6d130cb4662b3f07fca11c1e
+ 1b2e73e143508792e94bd7d35f2e0d68b837527a
+)
+
+package() {
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m755 "$srcdir/combustion.sh" "$pkgdir/etc/profile.d/combustion.sh"
+ cp -r "$srcdir/combustion-release" "$pkgdir/usr/share/$pkgname"
+}