summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgato_lento2017-04-24 09:34:37 -0500
committergato_lento2017-04-24 09:34:37 -0500
commitcbc8c9ea332fee3c383803863a2841f900baa0ff (patch)
tree6102ca1d54b34b97a97664054522366a54fea35f /PKGBUILD
parent4219342e7d0a9d2a62015452a6a249eb0aeb6d94 (diff)
downloadaur-cbc8c9ea332fee3c383803863a2841f900baa0ff.tar.gz
Remove extra LICENSE file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9a0fb4fa22a..6c657e6f8242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: gato_lento <vukk.euob at gmail>
pkgname=combustion
pkgver=0.6.2
-pkgrel=1
+pkgrel=2
pkgdesc='Sleek, modern web interface for Transmission'
arch=('any')
url='https://github.com/Secretmapper/combustion'
@@ -10,9 +10,9 @@ depends=('transmission-cli')
makedepends=('git')
source=(
- "git+https://github.com/Secretmapper/combustion.git"
- "combustion.sh"
- "combustion.conf"
+ git+https://github.com/Secretmapper/combustion.git
+ combustion.sh
+ combustion.conf
)
sha1sums=(
@@ -22,11 +22,11 @@ sha1sums=(
)
package() {
- install -D -m644 "$srcdir/combustion/LICENSE" "$pkgdir/usr/share/licenses/combustion/LICENSE"
- install -D -m755 "$srcdir/combustion.sh" "$pkgdir/etc/profile.d/combustion.sh"
- install -D -m644 "$srcdir/combustion.conf" "$pkgdir/usr/lib/systemd/system/transmission.service.d/combustion.conf"
- cd "$srcdir/combustion"
+ install -D -m755 $srcdir/combustion.sh $pkgdir/etc/profile.d/combustion.sh
+ install -D -m644 $srcdir/combustion.conf $pkgdir/usr/lib/systemd/system/transmission.service.d/combustion.conf
+ cd $srcdir/combustion
git checkout v${pkgver}
- cp -r "$srcdir/combustion" "$pkgdir/usr/share/"
- rm -rf "$pkgdir/usr/share/combustion/.git"
+ install -D -m644 $srcdir/combustion/LICENSE $pkgdir/usr/share/licenses/combustion/LICENSE
+ cp -r $srcdir/combustion $pkgdir/usr/share/
+ rm -rf $pkgdir/usr/share/combustion/{LICENSE,.git}
}