summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-11-07 19:15:29 +0100
committerTorsten Keßler2022-11-07 19:15:29 +0100
commit70a7f572a5ebc0236048198670029d86a5b0a8ea (patch)
treec41e8a7b7ca4412c8cf19068ced1d9a883ed63a9 /PKGBUILD
parent7ee525b445a1bc42e0a872cd659c5fd04fba70ea (diff)
downloadaur-70a7f572a5ebc0236048198670029d86a5b0a8ea.tar.gz
upgpkg: comgr 5.3.0-2
* Build tests and run them in check() * Overwrite default cmake build target with arch default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24e239e6cfe1..d728a07bc1e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=comgr
pkgdesc='Compiler support library for ROCm LLVM'
pkgver=5.3.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://github.com/RadeonOpenCompute/ROCm-CompilerSupport'
license=('custom:NCSAOSL')
@@ -20,10 +20,16 @@ build() {
-S "$_dirname/lib/comgr" \
-B build \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DCMAKE_PREFIX_PATH='/opt/rocm/llvm'
+ -DCMAKE_BUILD_TYPE=None \
+ -DBUILD_TESTING=ON \
+ -DCMAKE_PREFIX_PATH=/opt/rocm/llvm
cmake --build build
}
+check() {
+ cmake --build build --target check-comgr
+}
+
package() {
DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$_dirname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"