summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Dray2015-07-09 07:57:59 +1000
committerJustin Dray2015-07-09 08:00:15 +1000
commit787698121249354cf3c967bf55896c33a209b791 (patch)
tree9231a230e754006230a2b88bbd1d8c5558239998 /PKGBUILD
downloadaur-787698121249354cf3c967bf55896c33a209b791.tar.gz
Update to: 0.4.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0ec61efb657
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Matthias Maennich <arch@maennich.net>
+pkgname=command-not-found
+pkgver=0.4.5
+pkgrel=1
+pkgdesc="In case a command could not be found this utility searches for packages containing this or a similar command (bash,zsh)."
+arch=('i686' 'x86_64')
+url="http://github.com/metti/command-not-found"
+license=('GPL')
+depends=('boost-libs' 'tdb' 'libarchive' 'wget')
+makedepends=('boost' 'tdb' 'cmake' 'git')
+md5sums=('351ea2f4a1933f408bcb657070c191a4')
+install='command-not-found.install'
+source=("https://github.com/metti/command-not-found/archive/v${pkgver}.zip")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cmake -D CMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="" src
+ make
+}
+
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}