summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-04-09 13:54:14 +0800
committerzxp198210052024-04-09 13:54:14 +0800
commit00f0c5318f37ef6f25dda17b436fba9bb05377e6 (patch)
treea95beaebe857faf57eeb3ed792e5a66c8cfb44de /PKGBUILD
parentd5e8abd3ff47323d09e9189950253d5316aaab07 (diff)
downloadaur-00f0c5318f37ef6f25dda17b436fba9bb05377e6.tar.gz
update to 0.31.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f56840cb9501..063e36d19e62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=commas
_pkgname=Commas
-pkgver=0.30.0
-_electronversion=28
-_nodever=18
-pkgrel=4
+pkgver=0.31.0
+_electronversion=29
+_nodever=20
+pkgrel=1
pkgdesc="A hackable, pluggable terminal, and also a command runner."
arch=("x86_64")
url="https://github.com/CyanSalt/commas"
@@ -37,7 +37,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
gendesk -q -f -n --categories="Utility" --name="${_pkgname}" --exec="${pkgname} %U"
@@ -51,9 +51,9 @@ build() {
export npm_config_disturl=https://electronjs.org/headers
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi