summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-09-20 10:57:44 -0600
committerMark Wagie2021-09-20 10:57:44 -0600
commit512e5dc4e8c77ed7aefc07eea7cdf4cb62af78b6 (patch)
treee8cd76551a408e84825edfebd9804a429f50e67e /PKGBUILD
parent917f66843c851a8a3a100e2084b27f59838bd5ec (diff)
downloadaur-512e5dc4e8c77ed7aefc07eea7cdf4cb62af78b6.tar.gz
2.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f5a9d2db8c0..3ec7ce56dfa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=commit
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="Commit message editor."
arch=('x86_64')
@@ -13,19 +13,19 @@ optdepends=('git: git support'
'mercurial: mercurial support'
'gspell: spell checking support')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('9b6c9bc427229d2d0a539ab4dae27fe444a10c0db686e40af1b51a038bd2174f')
+sha256sums=('79f3d88eb8cdc0c0a024e3953f03db0faab5d0368e4a917c91321571f6ff32ed')
build() {
- arch-meson Commit-$pkgver build
- meson compile -C build
+ arch-meson Commit-$pkgver build
+ meson compile -C build
}
check() {
- # Validate appstream file fails, only validate desktop & schema files
- meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
+ # Validate appstream file fails, only validate desktop & schema files
+ meson test 'Validate desktop file' 'Validate schema file' -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}