summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-05-04 16:23:13 -0600
committerMark Wagie2021-05-04 16:23:13 -0600
commit6cfd53786581c71cadf297b73f305fddae9bbc87 (patch)
treef7bf81c709640ac44dfb3be8ebdfc7c7db0ad7cf /PKGBUILD
downloadaur-6cfd53786581c71cadf297b73f305fddae9bbc87.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..466c9bdc52bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=commit
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Git commit message editor."
+arch=('x86_64')
+url="https://github.com/sonnyp/Commit"
+license=('GPL3')
+depends=('git' 'gjs')
+makedepends=('meson')
+#checkdepends=('appstream-glib' 'desktop-file-utils')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('25878bf684f90e67bafa10e27da36df84959376ede3636f81eb03a56c1328a8c')
+
+build() {
+ arch-meson Commit-$pkgver build
+ meson compile -C build
+}
+
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}