summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Mullins2016-01-10 18:07:20 -0500
committerChristopher Mullins2016-01-10 18:07:20 -0500
commit016a0fdf71eb2efc442d1d8a5f558eb425550200 (patch)
tree7259838115954aa65feab4bee10f611afa343fee /PKGBUILD
parent404a428bf381e23b41874105331c572e25fe8b22 (diff)
downloadaur-016a0fdf71eb2efc442d1d8a5f558eb425550200.tar.gz
Add python wrapping by default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9bb23b11d26..dacd655350b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ pkgdesc='A set of common support code for medical imaging, surgical navigation,
pkgver=r5007.0f14f50
arch=('i686' 'x86_64')
url='http://commontk.org'
-depends=('qt4')
-makedepends=('git' 'cmake' 'subversion')
+depends=('qt4' 'pythonqt')
+makedepends=('git' 'cmake')
optdepends=('python2: For scripting support')
license=('Apache')
source=("git://github.com/commontk/CTK.git")
@@ -30,6 +30,13 @@ build() {
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DCTK_LIB_Widgets:BOOL=ON \
+ -DCTK_ENABLE_Python_Wrapping:BOOL=ON \
+ -DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY:PATH=/usr/lib64/libpython2.7.so \
+ -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2.7 \
+ -DPYTHONQT_INCLUDE_DIR:PATH=/usr/include/PythonQt \
+ -DPYTHONQT_INSTALL_DIR:PATH=/usr \
+ -DPYTHONQT_LIBRARY_RELEASE:FILEPATH=/usr/lib64/libPythonQt.so \
../CTK
make