summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Brennan2021-05-28 09:04:15 -0700
committerStephen Brennan2021-05-28 09:04:15 -0700
commit58ac5d762dae439debaca121db0b6c7cdbee13c2 (patch)
tree571412717db4758b7eb32eca1801c348f50e1e7c /PKGBUILD
parent2302fd4511d1de1440bc8f552807a2b10f262466 (diff)
downloadaur-58ac5d762dae439debaca121db0b6c7cdbee13c2.tar.gz
Update to 3.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4610fe969ebd..3974fc6af1e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,20 @@
# Maintainer: Stephen Brennan <smb196@case.edu>
+# Contributor: Arvedui <arvedui@posteo.de>
pkgname=communi-desktop
-pkgver=3.5.0
+pkgver=3.6.0
pkgrel=1
-epoch=
pkgdesc="An IRC client for desktop environments."
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'aarch64' 'arm' 'armv6h' 'armv7h')
url="https://communi.github.io/"
-license=('GPL')
-groups=()
+license=('BSD')
depends=('qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme' 'xdg-utils' 'libcommuni')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
+makedepends=('chrpath')
install=.INSTALL
-changelog=
source=("communi-desktop-v$pkgver.tar.gz::https://github.com/communi/$pkgname/archive/v$pkgver.tar.gz"
"communi-shared-v$pkgver.tar.gz::https://github.com/communi/communi-shared/archive/v$pkgver.tar.gz")
noextract=()
-md5sums=("5fd5d87a9f4ecdce86a7004915b3f094"
- "1f23bf566b7f676e041c9bfaa458e014")
+md5sums=("97764bc84a7c80c7d7f6724b6106fb03"
+ "379ca7959c9b8e1d4a004b29e1ad768f")
validpgpkeys=()
prepare() {
@@ -46,4 +37,6 @@ check() {
package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir" install
+
+ chrpath -d "${pkgdir}/usr/bin/communi"
}