summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXuanrui Qi2019-09-18 21:58:55 -0700
committerXuanrui Qi2019-09-18 21:58:55 -0700
commit02aa64f46b75130da85ee764c0855a76caef427b (patch)
treef68b64034de785c579b56aa4e6ae6a99e0630015 /PKGBUILD
parent738306712c35dc8550f4e55d9215c395f07cb11e (diff)
downloadaur-02aa64f46b75130da85ee764c0855a76caef427b.tar.gz
Release 3.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e19adc7b63d7..3fce54051626 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,23 @@
pkgname=compcert
_dirname=CompCert
-pkgver=3.5
-pkgrel=3
+pkgver=3.6
+pkgrel=1
pkgdesc="The formally verified C compiler"
arch=('x86_64')
url="http://compcert.inria.fr"
license=('custom:INRIA Non-Commercial License Agreement')
depends=('gcc')
-makedepends=('coq>=8.6.1' 'ocaml>=4.0.2'
- 'ocaml-menhir>=20161201' 'ocaml-menhir<=20181113'
+makedepends=('coq>=8.7.2' 'ocaml>=4.0.2'
+ 'ocaml-menhir>=20190626'
'ocaml-findlib' # See: https://github.com/AbsInt/CompCert/issues/281
- 'parallel')
-source=("http://compcert.inria.fr/release/$pkgname-$pkgver.tgz"
- "Makefile.patch"
- "Makefile-runtime.patch")
-sha1sums=('375705b2a02062d3af0906cb53d9a08a25382097'
- '12abd465a238501777573391c551deb1637a9384'
- '810e5efc65179168764221d4d7fd83b8340f61bb')
+ )
+checkdepends=('parallel')
+source=("http://compcert.inria.fr/release/$pkgname-$pkgver.tgz")
+sha1sums=('2b0da15587fc1676852d241a5cc11c66e094f483')
prepare() {
cd $srcdir/$_dirname-$pkgver
-
- # Fix missing $DESTDIR references in Makefile
- # Until upstream fixes this, we're forced to use this patch
- patch -Np0 -i ../Makefile.patch
- patch -Np0 -i ../Makefile-runtime.patch
}
build() {