summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXuanrui Qi2020-05-09 22:08:05 +0900
committerXuanrui Qi2020-05-09 22:08:05 +0900
commitd093a556467473ee79832ecc6e41d331f24c8bad (patch)
tree7afb66c086fda835e369fab1cad272c930c33ff5 /PKGBUILD
parent157f7c79e0661ca286263f873caafd7f377f46bc (diff)
downloadaur-d093a556467473ee79832ecc6e41d331f24c8bad.tar.gz
New version v3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0d6e6e94bc9..d33b20340725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=compcert
_dirname=CompCert
-pkgver=3.6
+pkgver=3.7
pkgrel=1
pkgdesc="The formally verified C compiler"
arch=('x86_64')
url="http://compcert.inria.fr"
license=('custom:INRIA Non-Commercial License Agreement')
depends=('gcc')
-makedepends=('coq>=8.7.2' 'ocaml>=4.0.2'
+makedepends=('coq>=8.8.0' 'ocaml>=4.05.0'
'ocaml-menhir>=20190626'
'ocaml-findlib' # See: https://github.com/AbsInt/CompCert/issues/281
)
checkdepends=('parallel')
source=("http://compcert.inria.fr/release/$pkgname-$pkgver.tgz")
-sha1sums=('2b0da15587fc1676852d241a5cc11c66e094f483')
+sha1sums=('63f327b7ee8a76fb720b7f1a644283d43dccd53a')
prepare() {
cd $srcdir/$_dirname-$pkgver
@@ -29,7 +29,7 @@ build() {
# -install-coqdev: also installs the Coq development, implied by -clightgen, useful
# if you will use tools such as the Princeton VST)
#
- # Current latest Coq version is 8.9.1, not officially supported but works, so ignoring Coq version
+ # Current latest Coq version is 8.11.0, not officially supported but works, so ignoring Coq version
./configure -ignore-coq-version -prefix /usr $CARCH-linux
make all