summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXuanrui Qi2019-05-28 22:05:43 -0400
committerXuanrui Qi2019-05-28 22:05:43 -0400
commit309dcfa6757835800aef0400d04642464ac11a2b (patch)
tree8096ea6b15b480d3705e13f0c3af20302945ff6e /PKGBUILD
parent4503d294b3ce2733faf318eb71047c84de8f229c (diff)
downloadaur-309dcfa6757835800aef0400d04642464ac11a2b.tar.gz
Added tests
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e3f8efdcac3..c36c8c659f8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=compcert-git
_basepkgname=${pkgname%-*}
_dirname=CompCert
-pkgver=3.5.r36.g5b7fc96a
-pkgrel=3
+pkgver=3.5.r50.ge1055531
+pkgrel=1
pkgdesc="The formally verified C compiler"
arch=('x86_64')
url="http://compcert.inria.fr"
@@ -12,7 +12,8 @@ depends=('gcc')
makedepends=('coq>=8.6.1' 'ocaml>=4.0.2'
'ocaml-menhir>=20161201' 'ocaml-menhir<=20181113'
'ocaml-findlib' # See: https://github.com/AbsInt/CompCert/issues/281
- 'git')
+ 'git'
+ 'parallel')
provides=($_basepkgname=$pkgver)
conflicts=($_basepkgname)
source=("git+https://github.com/AbsInt/CompCert.git")
@@ -39,6 +40,13 @@ build() {
make all
}
+check() {
+ cd $srcdir/$_dirname/test
+
+ make all
+ make parallel
+}
+
package() {
cd $srcdir/$_dirname
make DESTDIR=$pkgdir install