summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharles Bos2016-07-01 10:34:24 +0100
committerCharles Bos2016-07-01 10:34:24 +0100
commitc851cb5bb825f5c0f31824e4e3f1a6446a446079 (patch)
tree5b75d9265bbd923d7025860a34c3e3fb617963c9 /PKGBUILD
parent245993112431cc583cadfaf6ada7eb1132c1d007 (diff)
downloadaur-c851cb5bb825f5c0f31824e4e3f1a6446a446079.tar.gz
update to tarball for r4063 (Compiz 0.9.13.0)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 7 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 324e5cb07267..e4b380283476 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,41 +5,30 @@
# Contributor: Nathan Hulse <nat.hulse@gmail.com>
pkgname=compiz
-pkgver=0.9.12.2
-_pkgseries=0.9.12
-pkgrel=13
+pkgver=0.9.13.0
+_pkgseries=0.9.13
+pkgrel=1
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
-depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity>=3.16.0' 'glu' 'libsm' 'dconf')
+depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf')
makedepends=('cmake' 'intltool')
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
conflicts=('compiz-core')
-source=("https://launchpad.net/${pkgname}/${_pkgseries}/${pkgver}/+download/${pkgname}-${pkgver}.tar.bz2"
+source=("http://bazaar.launchpad.net/~compiz-team/compiz/0.9.12/tarball/4063"
"focus-prevention-disable.patch"
"gtk-extents.patch"
- "xfce4-notifyd-nofade.patch"
- "c++11.patch"
- "switcher-background.patch"
- "cmake3.patch"
- "cube-texture.patch"
- "marco-in-mate.patch"
"trailfocus-fix.patch")
-sha256sums=('8917ac9e6dfdacc740780e1995e932ed865d293ae87821e7a280da5325daec80'
+sha256sums=('SKIP'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
- '273aa79cb0887922e3a73fbbe97596495cee19ca6f4bd716c6c7057f323d8198'
- 'eb8b432050d1eed9cb1d5f33d2645f81e2bdce2bf55d5cc779986bb751373a45'
- 'e3125ed3a7e87a7d4bdaa23f1b6f654a02d0b050ad7a694ce9165fff2c6ff310'
- 'e5016fd62f9c9659d887eeafd556c18350615cd6d185c8ffa08825465890c5e0'
- '81780f8c56f5b27b09394ae9ed59d10ae50c58f9ade445e9f85d7c2a00445f7e'
- '0d7474aee60c1a482cf26d5d0be6ec2e1b1067fa1d601fdf4aa19a71b07e41d3'
'01e94ac52cd39eb5462a8505c7df61c7b14b05159de64f8700dfadb524bdb2ce')
prepare() {
+ mv "${srcdir}/~compiz-team/compiz/0.9.12" "${srcdir}/${pkgname}-${pkgver}"
cd "${pkgname}-${pkgver}"
# Fix decorator start command
@@ -55,24 +44,6 @@ prepare() {
# Fix incorrect extents for GTK+ tooltips, csd etc
patch -Np1 -i "${srcdir}/gtk-extents.patch"
- # Ensure xfce4 notifications are not 'double faded'
- patch -Np1 -i "${srcdir}/xfce4-notifyd-nofade.patch"
-
- # Use C++11 (pre-requisite for switcher-background.patch)
- patch -Np1 -i "${srcdir}/c++11.patch"
-
- # Allow user to change switcher background colour (fixes blank background for Emerald)
- patch -Np1 -i "${srcdir}/switcher-background.patch"
-
- # Get rid of the cmake policy warning messages
- patch -Np1 -i "${srcdir}/cmake3.patch"
-
- # Fix off-center cube cap pictures
- patch -Np1 -i "${srcdir}/cube-texture.patch"
-
- # Use the Marco gsettings in MATE session (commits 3997+4002)
- patch -p1 -i "${srcdir}/marco-in-mate.patch"
-
# Fix ambiguous function call in trailfocus plugin
patch -Np1 -i "${srcdir}/trailfocus-fix.patch"
}
@@ -94,12 +65,9 @@ build() {
-DBUILD_GTK=On \
-DBUILD_METACITY=On \
-DBUILD_KDE4=Off \
- -DUSE_GCONF=Off \
- -DUSE_GSETTINGS=On \
-DCOMPIZ_BUILD_TESTING=Off \
-DCOMPIZ_WERROR=Off \
-DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp" \
- -DCOMPIZ_DISABLE_PLUGIN_DBUS=On
make
}
@@ -123,7 +91,4 @@ package() {
install -dm755 "${pkgdir}/usr/share/glib-2.0/schemas/"
install -m644 generated/glib-2.0/schemas/*.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/"
fi
-
- # Remove GConf schemas
- rm -rv "${pkgdir}/usr/share/gconf/"
}