summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2016-04-11 13:26:27 -0700
committerShadowKyogre2016-04-11 13:26:27 -0700
commit38e88a3b2d269333619a6fb253d865544cdf0e49 (patch)
tree3dc17f52875622090f196e1847ab08b196c3ceb1 /PKGBUILD
parentb410d5aaca77ed7a15bce5b8656e3d19626878b2 (diff)
downloadaur-38e88a3b2d269333619a6fb253d865544cdf0e49.tar.gz
Update using Github URLs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD97
1 files changed, 67 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6e6fa42ab6e..b3a64bd55ad5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,84 @@
# Maintainer: martadinata666 <martadinata666@gmail.com>
-pkgname=compiz-core
-pkgver=0.8.12
+_use_marco=0
+
+_upstream="compiz"
+_pkgver=0.8.12
+_micro=.3
+
+pkgbase=compiz-core
+pkgname=(compiz-core compiz-gtk)
+pkgver="${_pkgver}${_micro}"
pkgrel=1
pkgdesc="This is the latest stable release of Compiz without DE deps"
-url="http://blog.northfield.ws/compiz-0-8-12-release-announcement/"
+url="https://github.com/compiz-reloaded/${_upstream}/"
license=('GPL' 'LGPL' 'MIT')
arch=('i686' 'x86_64')
depends=('startup-notification' 'librsvg' 'dbus' 'glu' 'libxslt' 'libxrandr' 'libsm' 'libxcomposite' 'libxinerama')
-makedepends=('intltool' 'gconf' 'libice')
+makedepends=('intltool' 'libice')
options=(!libtool !emptydirs)
-conflicts=('compiz' 'compiz-core' 'compiz-core-git' 'compiz-git')
-provides=("compiz-core=$pkgver")
-source=("compiz-core-${pkgver}.tar.xz::http://www.northfield.ws/projects/compiz/releases/${pkgver}/core.tar.xz")
+source=("${url}/releases/download/v${pkgver}/${_upstream}-${pkgver}.tar.xz")
+
+_configure_opts=(
+ --prefix=/usr
+ --enable-shared
+ --enable-dbus
+ --enable-dbus-glib
+ --enable-librsvg
+ --enable-glib
+ --disable-static
+ --disable-inotify
+)
+
+if (("${_use_marco}"));then
+ _configure_opts+=("--enable-marco")
+ makedepends+=("marco")
+ msg "Marco theme support enabled"
+else
+ _configure_opts+=("--disable-marco")
+ msg "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it"
+fi
build()
{
- cd $srcdir/core
-
- ./autogen.sh \
- --prefix=/usr \
- --enable-shared \
- --disable-gtk \
- --enable-dbus \
- --enable-dbus-glib \
- --enable-librsvg \
- --enable-glib \
- --disable-gconf \
- --disable-gnome \
- --disable-gnome-keybindings \
- --disable-metacity \
- --disable-kde \
- --disable-kde4 \
- --disable-kconfig \
- --disable-static \
- --disable-inotify \
+ cd "${srcdir}/${_upstream}-${pkgver}"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure "${_configure_opts[@]}"
make
}
-package() {
- cd "$srcdir/core"
- make DESTDIR="$pkgdir" install
+package_compiz-core() {
+ cd "${srcdir}/${_upstream}-${pkgver}"
+
+ pkgdesc+=" (Core w/o decorator)"
+ provides=("compiz-core=$pkgver")
+ conflicts=('compiz' 'compiz-core-git' 'compiz-git')
+
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}/usr/bin/gtk-window-decorator"
+ rm "${pkgdir}/usr/share/glib-2.0/schemas/org.compiz-0.gwd.gschema.xml"
+ rm "${pkgdir}/usr/share/icons/hicolor/"*"/apps/gtk-decorator."*
+}
+
+package_compiz-gtk()
+{
+ if (("${_use_marco}"));then
+ #separating libmarco-private would be nice, but this is a workaround for now
+ depends+=('marco')
+ fi
+ pkgdesc+=" (GTK+ window decorator)"
+ conflicts=('compiz-gtk-git')
+
+ cd "${srcdir}/${_upstream}-${pkgver}/gtk"
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}/usr/share/applications/compiz.desktop"
+
+ cd "${srcdir}/${_upstream}-${pkgver}/images"
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}/usr/share/icons/hicolor/"*"/apps/compiz."*
+ rm "${pkgdir}/usr/share/compiz/"*.png
}
-sha256sums=('ea558a7c55d8097bd39ecbc8d98dc8dde989eb12612d88472435fafa34ecd3d8')
+sha256sums=('6fc5176e3af5d6f434f26d1b654460aeeb3faf723db37f0957b46c2c23955032')