summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2015-08-13 10:46:49 -0700
committerShadowKyogre2015-08-13 10:46:49 -0700
commit96bc2ad25528710eca3f235a059207526bed282e (patch)
tree88fc23175d6ea85ef7f8a4df78e8be642361fe33 /PKGBUILD
downloadaur-96bc2ad25528710eca3f235a059207526bed282e.tar.gz
Export from AUR3 to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a335b0cc7e86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: martadinata666 <martadinata666@gmail.com>
+
+pkgname=compiz-core
+pkgver=0.8.10
+pkgrel=1
+pkgdesc="This is the latest stable release of Compiz without DE deps"
+url="http://blog.northfield.ws/compiz-0-8-10-release-announcement/"
+license=('GPL' 'LGPL' 'MIT')
+arch=('i686' 'x86_64')
+depends=('startup-notification' 'librsvg' 'dbus' 'glu' 'libxslt' 'libxrandr' 'libsm' 'libxcomposite' 'libxinerama')
+makedepends=('intltool' 'gconf' 'libice')
+options=(!libtool !emptydirs)
+conflicts=('compiz' 'compiz-core' 'compiz-core-git' 'compiz-git')
+provides=("compiz-core=$pkgver")
+source=(http://www.northfield.ws/projects/compiz/releases/${pkgver}/core.tar.gz)
+
+md5sums=('a502e17eb7f61c5c66ec889c019a1f62')
+
+build()
+{
+ cd $srcdir/core
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-gtk \
+ --enable-dbus \
+ --enable-dbus-glib \
+ --enable-librsvg \
+ --enable-glib \
+ --disable-gconf \
+ --disable-gnome \
+ --disable-gnome-keybindings \
+ --disable-metacity \
+ --disable-kde \
+ --disable-kde4 \
+ --disable-kconfig \
+ --disable-static \
+ --disable-inotify \
+
+ make
+}
+
+package() {
+ cd "$srcdir/core"
+ make DESTDIR="$pkgdir" install
+}