summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2015-12-14 19:41:36 -0800
committerShadowKyogre2015-12-14 19:41:36 -0800
commit23d136f6c267aec1e0f7ef11d60d3ba734e6ef23 (patch)
tree030a84dd1fb93eb3b4e185b3b0f324f4eba654dd /PKGBUILD
downloadaur-23d136f6c267aec1e0f7ef11d60d3ba734e6ef23.tar.gz
Make gitified compiz PKGBUILD: compiz-core-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83e929ae4eb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: martadinata666 <martadinata666@gmail.com>
+
+pkgname=compiz-core-git
+pkgver=compiz.0.8.10.r1.gab72c84
+pkgrel=1
+pkgdesc="This is the latest stable release of Compiz without DE deps"
+url="http://git.northfield.ws/compiz/?p=compiz/core;a=summary"
+license=('GPL' 'LGPL' 'MIT')
+arch=('i686' 'x86_64')
+depends=('startup-notification' 'librsvg' 'dbus' 'glu' 'libxslt' 'libxrandr' 'libsm' 'libxcomposite' 'libxinerama')
+makedepends=('intltool' 'libice')
+options=(!libtool !emptydirs)
+conflicts=('compiz' 'compiz-core')
+provides=("compiz-core=$pkgver")
+source=(
+ 'git://northfield.ws/compiz/core'
+)
+
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/core"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build()
+{
+ cd $srcdir/core
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-gtk \
+ --enable-dbus \
+ --enable-dbus-glib \
+ --enable-librsvg \
+ --enable-glib \
+ --disable-gconf \
+ --disable-gnome \
+ --disable-gnome-keybindings \
+ --disable-metacity \
+ --disable-kde \
+ --disable-kde4 \
+ --disable-kconfig \
+ --disable-static \
+ --disable-inotify \
+
+ make
+}
+
+package() {
+ cd "$srcdir/core"
+ make DESTDIR="$pkgdir" install
+}