summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2017-04-04 13:05:05 -0700
committerShadowKyogre2017-04-04 13:05:05 -0700
commita0c0e140b95bc209c62d52ee6ad0e4399a5d931d (patch)
treec3a3c8bd9863b94463f7cf50d921f71b5dcbf06f /PKGBUILD
parent463b042c884111eafb28ac9963aaffd2f89956cb (diff)
downloadaur-a0c0e140b95bc209c62d52ee6ad0e4399a5d931d.tar.gz
marco theme with GTK3 as default, namcap tidying
Prior to this commit, _use_marco=1 enabled GTK+2 support for Marco themes. _use_marco=2 enabled GTK+3 support for Marco themes. MATE upstream wise now only supports GTK+3. GTK+2 versions of the MATE desktop components are now in the AUR. Following this paradigm, _use_marco=1 will represent the distribution default marco (whether that represents GTK+2 or GTK+3). And _use_marco=2 will represent the alternative choice. Other than that, the following changes were made after running the built packages through namcap: * Explicitly list the compiz-core-git as a dependency for compiz-gtk-git * Add missed dependencies of libxi and libxcursor for compiz-core-git * Add missed dependency of hicolor-icon-theme for compiz-core-git * List libwnck/libwnck3 dependencies instead of gtk2/gtk3 dependencies for the nonmarco components since the decorator also pulls in libwnck.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 32 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 620527b2529f..6763c2663601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
# Contributor: martadinata666 <martadinata666@gmail.com>
+# Flag for whether to use marco
_use_marco=0
+# Flag for whether to use GTK+3
+# Autoset depending on marco option
+_use_gtk3=0
+
_upstream="compiz"
pkgbase=compiz-core-git
pkgname=(compiz-core-git compiz-gtk-git)
-pkgver=0.8.12.3.r24.g292d9a2
-pkgrel=2
+pkgver=0.8.12.3.r84.g20335d7d
+pkgrel=1
pkgdesc="This is the latest git release of Compiz without DE deps"
url="https://github.com/compiz-reloaded/${_upstream}"
license=('GPL' 'LGPL' 'MIT')
@@ -37,16 +42,25 @@ _configure_opts=(
if (("${_use_marco}" == 1));then
_configure_opts+=("--enable-marco")
makedepends+=("marco")
- msg "Marco theme support enabled"
+ _use_gtk3=1
+ msg "Marco theme support enabled with GTK+3"
elif (("${_use_marco}" == 2));then
_configure_opts+=("--enable-marco")
- _configure_opts+=("--with-gtk=3.0")
- makedepends+=("marco-gtk3")
- msg "Marco theme support enabled with GTK+3"
+ makedepends+=("marco-gtk2")
+ _use_gtk3=0
+ msg "Marco theme support enabled with GTK+2"
else
_configure_opts+=("--disable-marco")
msg "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it"
- msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk3"
+ msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2"
+fi
+
+if (("${_use_gtk3}" >= 1)); then
+ _configure_opts+=("--with-gtk=3.0")
+ msg "Using GTK+3 for gtk-window-decorator"
+else
+ _configure_opts+=("--with-gtk=2.0")
+ msg "Using GTK+2 for gtk-window-decorator"
fi
pkgver() {
@@ -74,6 +88,7 @@ package_compiz-core-git() {
cd "$srcdir/${_upstream}"
pkgdesc+=" (Core w/o decorator)"
+ depends+=('hicolor-icon-theme' 'libxi' 'libxcursor')
provides=("compiz-core=$pkgver")
conflicts=('compiz' 'compiz-core')
@@ -95,14 +110,21 @@ package_compiz-core-git() {
package_compiz-gtk-git()
{
+ depends+=('compiz-core-git')
#separating libmarco-private would be nice, but this is a workaround for now
if (("${_use_marco}" == 1));then
- depends+=('marco')
+ depends+=('marco-gtk2')
elif (("${_use_marco}" == 2));then
- depends+=('marco-gtk3')
+ depends+=('marco')
+ fi
+
+ if (( "${_use_gtk3}" >= 1 ));then
+ depends+=('libwnck3')
else
- depends+=('gtk2')
+ depends+=('libwnck')
fi
+
+
pkgdesc+=" (GTK+ window decorator)"
provides=("compiz-gtk=$pkgver")
conflicts=('compiz-gtk')