summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2020-04-25 07:57:18 -0700
committerShadowKyogre2020-04-25 07:57:18 -0700
commitbc5ce630844e9f9988883a1f0f095c447059bcba (patch)
tree5af8c9c1705ab343d617e58a18a74eb7f4f997b5 /PKGBUILD
parent8ebfd849cc20e0958ccbbebc91bf42447c7e48a3 (diff)
downloadaur-bc5ce630844e9f9988883a1f0f095c447059bcba.tar.gz
Change msg2 to echo to stderr
https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_etiquette
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b530bc91af02..597517897849 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _upstream="compiz-core"
pkgbase=compiz-core-git
pkgname=(compiz-core-git compiz-gtk-git)
-pkgver=0.8.14.r43.g09b96469
+pkgver=0.8.18.r0.gae031701
pkgrel=1
pkgdesc="This is the latest git release of Compiz without DE deps"
url="https://gitlab.com/compiz/${_upstream}"
@@ -46,24 +46,24 @@ if (("${_use_marco}" == 1));then
_configure_opts+=("--enable-marco")
makedepends+=("marco")
_use_gtk3=1
- msg "Marco theme support enabled with GTK+3"
+ echo "Marco theme support enabled with GTK+3" >&2
elif (("${_use_marco}" == 2));then
_configure_opts+=("--enable-marco")
makedepends+=("marco-gtk2")
_use_gtk3=0
- msg "Marco theme support enabled with GTK+2"
+ echo "Marco theme support enabled with GTK+2" >&2
else
_configure_opts+=("--disable-marco")
- msg "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it"
- msg "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2"
+ echo "Marco theme support disabled, rebuild with _use_marco=1 in the PKGBUILD if you want it" >&2
+ echo "Rebuild with _use_marco=2 in the PKGBUILD if you have marco-gtk2" >&2
fi
if (("${_use_gtk3}" >= 1)); then
_configure_opts+=("--with-gtk=3.0")
- msg "Using GTK+3 for gtk-window-decorator"
+ echo "Using GTK+3 for gtk-window-decorator" >&2
else
_configure_opts+=("--with-gtk=2.0")
- msg "Using GTK+2 for gtk-window-decorator"
+ echo "Using GTK+2 for gtk-window-decorator" >&2
fi
pkgver() {
@@ -80,7 +80,7 @@ build()
if ! grep -q pkg_cv_GTK config.log;then
# make sure only compiz-core-git is created if gtk is missing
- msg "Making sure only $pkgbase is made, gtk+2 or gtk+3 is missing"
+ echo "Making sure only $pkgbase is made, gtk+2 or gtk+3 is missing" >&2
pkgname=("$pkgbase")
fi