summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCharles Bos2019-11-17 19:59:26 +0000
committerCharles Bos2019-11-17 19:59:26 +0000
commite2a233d74fba25126b210c47bd59ad23e8dcb890 (patch)
tree983a88c9e1fbc1f1ec166925b2048784b026e6f8 /PKGBUILD
parent1027589694aa5da4dd107d79161ef2325fd09e00 (diff)
downloadaur-e2a233d74fba25126b210c47bd59ad23e8dcb890.tar.gz
Add ccsm-escape-fix.patch - thanks rharish
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25eb6d6b575c..8cc4737d9040 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Nathan Hulse <nat.hulse@gmail.com>
pkgname=compiz-git
-pkgver=0.9.14.0.r0.gb340cc413
-pkgrel=2
+pkgver=0.9.14.0.r1.gfac27fe9a
+pkgrel=1
_gitname=compiz
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM (development version)"
arch=('i686' 'x86_64')
@@ -25,13 +25,15 @@ source=("git+https://git.launchpad.net/${_gitname}"
"gtk-extents.patch"
"reverse-unity-config.patch"
"screenshot-launch-fix.patch"
- "no-compile-gschemas.patch")
+ "no-compile-gschemas.patch"
+ "ccsm-escape-fix.patch")
sha256sums=('SKIP'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
'6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b'
'89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
- '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a'
+ '033c3be1f54238d07b4ed400d34b2260247ed7269fa281e98eb551b08b9a9188')
pkgver() {
cd "${_gitname}"
@@ -55,6 +57,9 @@ prepare() {
# Don't try to compile gschemas during make install
patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
+
+ # Fix HTML-escaping related ccsm crashes
+ patch -p1 -i "${srcdir}/ccsm-escape-fix.patch"
}
build() {