summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:27 +0300
committerDet2015-06-14 04:14:15 +0300
commitf02fa29604c81b6b0de5f83a75473a5a7f5bfa46 (patch)
treeafc40fec5998cbfff53df51ffe920f584613832c /PKGBUILD
downloadaur-f02fa29604c81b6b0de5f83a75473a5a7f5bfa46.tar.gz
Initial import: 0.4.2.4.r52.gef261dc-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..507ab9609411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Based on [extra]'s compositeproto: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/compositeproto
+
+_pkgname=compositeproto
+pkgname=$_pkgname-git
+pkgver=0.4.2.4.r52.gef261dc
+pkgrel=1
+pkgdesc="X11 Composite extension wire protocol - Git version"
+arch=('any')
+url="http://cgit.freedesktop.org/xorg/proto/$_pkgname/"
+license=('custom')
+depends=('fixesproto')
+makedepends=('git' 'xorg-util-macros')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("git://anongit.freedesktop.org/xorg/proto/$_pkgname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ echo $(git describe --long | cut -d "-" -f2-3 | tr - .).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)
+}
+
+build() {
+ cd $_pkgname
+
+ msg2 "Starting autogen.sh..."
+ ./autogen.sh --prefix=/usr
+
+ msg2 "Starting make..."
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ msg2 "Starting make install..."
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+}