summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlaf Leidinger2017-07-27 20:38:35 +0200
committerOlaf Leidinger2017-07-27 20:38:35 +0200
commita6ca263d2947ea15b7eb569f3cf850e2f9d7ea39 (patch)
treefe0978e6400e6c5ce528b9e0ed824c536e544f15 /PKGBUILD
downloadaur-a6ca263d2947ea15b7eb569f3cf850e2f9d7ea39.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed4da9696717
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Olaf Leidinger <oleid@mescharet.de>
+#
+# Get the CentOS tarball from https://www.codeplay.com/products/computesuite/computecpp/download
+pkgname=computecpp
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Accelerates Complex C++ Applications on Heterogeneous Compute
+Systems using Open Standards"
+arch=('x86_64')
+url="https://www.codeplay.com/products/computesuite"
+license=('EULA')
+source=("file://ComputeCpp-CE-${pkgver}-CentOS-64bit.tar.gz")
+sha256sums=('e7e301bcd8906b419d0067c262dc0eac987798da9dbac4763d285c1e9bf8ddec')
+
+package() {
+ _pkgbasename=ComputeCpp-CE-${pkgver}-Linux
+ cd "$srcdir"
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/etc/ld.so.conf.d"
+
+ mv ${_pkgbasename} "$pkgdir/opt"
+
+ ln -s /opt/${_pkgbasename}/bin/compute++ "$pkgdir/usr/bin"
+ ln -s /opt/${_pkgbasename}/bin/computecpp_info "$pkgdir/usr/bin"
+
+ echo /opt/${_pkgbasename}/lib > "$pkgdir/etc/ld.so.conf.d/computecpp.conf"
+}