summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTD-Sky2024-12-28 14:24:43 +0800
committerTD-Sky2024-12-28 14:24:43 +0800
commitac09a82110d943978f2c7df90b3e382252ac9f29 (patch)
tree9d89fb7a57edbd98374f8f354b850b13a90a89fe /PKGBUILD
parent9917a5f0031bb8ae80caf42e565a2d19a01d56cf (diff)
downloadaur-ac09a82110d943978f2c7df90b3e382252ac9f29.tar.gz
0.5.7-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25128368461e..5a95b992d192 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=conceal
pkgver=0.5.7
-pkgrel=1
+pkgrel=2
pkgdesc="Command line recycle bin"
arch=('x86_64')
url="https://github.com/TD-Sky/conceal"
@@ -17,30 +17,31 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('4612e4617b62ef4e9402b9372c1d418a907a8df2ffe711cf3fe98fc936319e68')
prepare() {
- cd "$pkgname-$pkgver"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd "$pkgname-$pkgver"
- cargo build --release --frozen
+ export CONCEAL_GEN_COMPLETIONS='true'
+ cd "$pkgname-$pkgver"
+ cargo build --release --frozen
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
- install -Dm 755 "target/release/conceal" -t "$pkgdir/usr/bin"
- install -Dm 644 "completions/conceal/_conceal" -t "$pkgdir/usr/share/zsh/site-functions"
- install -Dm 644 "completions/conceal/conceal.bash" "$pkgdir/usr/share/bash-completion/completions/conceal"
- install -Dm 644 "completions/conceal/conceal.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
- install -Dm 644 "completions/conceal/conceal.nu" -t "$pkgdir/usr/share/nushell/completions"
+ install -Dm 755 "target/release/conceal" -t "$pkgdir/usr/bin"
+ install -Dm 644 "completions/conceal/_conceal" -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm 644 "completions/conceal/conceal.bash" "$pkgdir/usr/share/bash-completion/completions/conceal"
+ install -Dm 644 "completions/conceal/conceal.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/conceal/conceal.nu" -t "$pkgdir/usr/share/nushell/completions"
- install -Dm 755 "target/release/cnc" -t "$pkgdir/usr/bin"
- install -Dm 644 "completions/cnc/_cnc" -t "$pkgdir/usr/share/zsh/site-functions"
- install -Dm 644 "completions/cnc/cnc.bash" "$pkgdir/usr/share/bash-completion/completions/cnc"
- install -Dm 644 "completions/cnc/cnc.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
- install -Dm 644 "completions/cnc/cnc.nu" -t "$pkgdir/usr/share/nushell/completions"
+ install -Dm 755 "target/release/cnc" -t "$pkgdir/usr/bin"
+ install -Dm 644 "completions/cnc/_cnc" -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm 644 "completions/cnc/cnc.bash" "$pkgdir/usr/share/bash-completion/completions/cnc"
+ install -Dm 644 "completions/cnc/cnc.fish" -t "$pkgdir/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/cnc/cnc.nu" -t "$pkgdir/usr/share/nushell/completions"
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}