summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Nicoulaud2018-11-25 22:38:36 +0100
committerJulien Nicoulaud2018-11-25 22:38:36 +0100
commit3a85fa90b1c43376029aa5ceafa75d0479bf45f8 (patch)
treef4db0c6053935d1a93fce9d2e5fabe83899a20ab /PKGBUILD
parentb27799704899fbf5561afc7401d48ec140a64914 (diff)
downloadaur-3a85fa90b1c43376029aa5ceafa75d0479bf45f8.tar.gz
Update for current master (please note tests do not pass at the time I write this)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a300b07b8e6..22ecc2edb00e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: pancho horrillo <pancho at pancho dot name>
# Maintainer: Bram Swenson <bram at amplified dot work>
# Contributor: Marti Raudsepp <marti at juffo dot org>
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
_pkgname='concourse-fly'
pkgname="${_pkgname}-git"
-pkgver=3.12.1.rc.8.r0.gbb37e22
-pkgrel=2
+pkgver=4.2.1.r9287.gee3b4cf8b
+pkgrel=1
pkgdesc='Command line interface to the Concourse continuous integration tool'
arch=('x86_64')
url='https://concourse-ci.org/fly.html'
@@ -19,33 +20,29 @@ source=("git+https://github.com/concourse/${_srcname}.git")
sha512sums=('SKIP')
prepare() {
- cd "${_srcname}"
- git submodule update --init --recursive
- export GOPATH="$PWD"
- go get github.com/onsi/ginkgo/ginkgo
+ cd "${srcdir}/${_srcname}"
+ git submodule update --init --recursive --jobs $(nproc) --recommend-shallow
}
pkgver() {
- cd "${_srcname}"
- cd src/github.com/concourse/fly
+ cd "${srcdir}/${_srcname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_srcname}"
+ cd "${srcdir}/${_srcname}/fly"
export GOPATH="$PWD"
- cd src/github.com/concourse/fly
go build
}
check() {
- cd "${_srcname}"
+ cd "${srcdir}/${_srcname}/fly"
export GOPATH="$PWD"
- cd src/github.com/concourse/fly
+ go get github.com/onsi/ginkgo/ginkgo
"$GOPATH"/bin/ginkgo -r
}
package() {
- cd "${_srcname}"
- install -m 755 -D src/github.com/concourse/fly/fly "$pkgdir"/usr/bin/fly
+ cd "${srcdir}/${_srcname}/fly"
+ install -m 755 -D fly "$pkgdir"/usr/bin/fly
}