summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortocic2023-06-20 08:42:44 +0300
committertocic2023-06-20 08:42:44 +0300
commit7388512eb32335c2cbd39cec45659c6dc6b25635 (patch)
tree6a4457d0243f567a0778c6a6c048f4a457ff5b49 /PKGBUILD
downloadaur-7388512eb32335c2cbd39cec45659c6dc6b25635.tar.gz
Add build files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8dd81dc8ee5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: tocic <tocic at protonmail dot ch>
+
+pkgname=concurrentqueue
+pkgdesc="A fast multi-producer, multi-consumer lock-free concurrent queue for C++11"
+pkgver=1.0.4
+pkgrel=1
+arch=("any")
+url="https://github.com/cameron314/concurrentqueue"
+license=("Boost" "BSD" "ZLIB")
+makedepends=("cmake")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cameron314/concurrentqueue/archive/v${pkgver}.tar.gz")
+b2sums=("8019a82e8cac2130e6565a07a153f17762673d1b1254e824ab0aadc9424836452ab89471513975cceb6f161a04480d58ea56679673c8459136d735d4df2de863")
+
+build() {
+ cmake -B "build/" -S "${pkgname}-${pkgver}" \
+ -D CMAKE_INSTALL_PREFIX:PATH="/usr/" \
+ -Wno-dev
+
+ cmake --build "build/"
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install "build/"
+
+ install -D --target-directory="${pkgdir}/usr/share/licenses/${pkgname}/" \
+ --mode=644 \
+ "${pkgname}-${pkgver}/LICENSE.md"
+}