summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgit user2023-12-19 16:12:49 +0100
committergit user2023-12-19 16:12:49 +0100
commite5d192589ed7c96aa30b8e7467db3c4b787308b1 (patch)
treed404573a174c413920f1901d0c2b278817e1973c /PKGBUILD
parentd8a283536f76cb8ede939a0a486c58f2a488b3b4 (diff)
downloadaur-confclerk-git.tar.gz
(1) Now getting the manpage also from a git repository,
(2) Upstream version bump.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 29 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1c33504a20c..04f15189bb70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@ _pkgname=confclerk
pkgname="${_pkgname}-git"
_pkgver=latest
epoch=1
-pkgver=0.6.4_1+r605.20171208.g4498f2e
+pkgver=0.7.1+1+r646.20210819.g4e8061f
pkgrel=1
-pkgdesc='QT4/QT5 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.'
+pkgdesc='Qt5 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.'
arch=('i686' 'x86_64')
url="http://www.toastfreeware.priv.at/confclerk"
-license=('GPLv2')
+license=('GPL2')
depends=(
- # 'qt4' # QT4 or AT5 are possible. Change also the corresponding qmake-statement in build() accordingly.
+ 'gcc-libs'
+ 'glibc'
'qt5-base'
)
optdepends=()
@@ -25,31 +26,41 @@ provides=(
conflicts=("${_pkgname}")
options=()
-pkgver() {
- cd "${srcdir}/${_pkgname}"
- _descr="$(git describe --tags)"
- _ver="$(printf '%s' "${_descr}" | cut -d '-' -f 1,2 | tr '-' '_')"
- _rev="r$(git rev-list --count HEAD)"
- _hash="$(printf '%s' "${_descr}" | cut -d '-' -f 3)"
- _date="$(git log -n 1 --format=tformat:%ci | cut -d ' ' -f 1 | tr -d '-')"
- printf '%s\n' "${_ver}+${_rev}.${_date}.${_hash}"
-}
-
source=(
"${_pkgname}::git+http://git.toastfreeware.priv.at/toast/confclerk.git"
- "${_pkgname}.1.gz::http://manpages.ubuntu.com/manpages.gz/zesty/man1/confclerk.1.gz"
+ "${_pkgname}-debian::git+http://git.toastfreeware.priv.at/debian/confclerk.git" # Needed for the manpage.
+ #"${_pkgname}.1.gz::http://manpages.ubuntu.com/manpages.gz/zesty/man1/confclerk.1.gz"
)
sha256sums=(
'SKIP'
'SKIP'
+ #'SKIP'
)
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ git log > git.log
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ _descr="$(git describe --tags)"
+ _ver="$(printf '%s' "${_descr}" | cut -d '-' -f 1,2 | tr '-' '+')"
+ _rev="r$(git rev-list --count HEAD)"
+ _hash="$(printf '%s' "${_descr}" | cut -d '-' -f 3)"
+ _date="$(git log -n 1 --format=tformat:%ci | cut -d ' ' -f 1 | tr -d '-')"
+ printf '%s\n' "${_ver}+${_rev}.${_date}.${_hash}"
+}
+
build() {
cd "${srcdir}/${_pkgname}"
- # qmake-qt4 # QT4 or QT5 possible. Change also the dependency accordingly.
- qmake-qt5
+ qmake
make
+
+ gzip -c -9 "${srcdir}/${_pkgname}-debian/data/confclerk.1" > "${srcdir}/${_pkgname}.1.gz"
+
}
package() {
@@ -63,5 +74,5 @@ package() {
install -v -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}/${_pkgname}" # Yes, we have an _additional_ ${_pkgname}-subdirectory, since we also have historic documentation from the time when this software was named fosdem-schedule.
cp -rv docs/* "${pkgdir}/usr/share/doc/${_pkgname}/"
- install -v -m644 AUTHORS BUGS COPYING INSTALL NEWS README "${pkgdir}/usr/share/doc/${_pkgname}/${_pkgname}"
+ install -v -D -m644 -t "${pkgdir}/usr/share/doc/${_pkgname}/${_pkgname}" AUTHORS BUGS COPYING INSTALL NEWS README git.log
}