summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfelics2020-03-08 20:23:45 +0100
committerfelics2020-03-08 20:23:45 +0100
commitd8a283536f76cb8ede939a0a486c58f2a488b3b4 (patch)
treea8c5cb3dc23747632f4a420c7ee2248243de0dc1 /PKGBUILD
parentf248e473419497b120fbff8eeef3ee84e535f784 (diff)
downloadaur-d8a283536f76cb8ede939a0a486c58f2a488b3b4.tar.gz
Ported to QT5, and made $pkgver monotoneously increasing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13552958723d..e1c33504a20c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
_pkgname=confclerk
pkgname="${_pkgname}-git"
-_pkgver=0.6.2
-pkgver=0.6.4_1+g4498f2e
+_pkgver=latest
+epoch=1
+pkgver=0.6.4_1+r605.20171208.g4498f2e
pkgrel=1
-pkgdesc='QT4 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.'
+pkgdesc='QT4/QT5 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.'
arch=('i686' 'x86_64')
url="http://www.toastfreeware.priv.at/confclerk"
license=('GPLv2')
depends=(
- 'qt4'
+ # 'qt4' # QT4 or AT5 are possible. Change also the corresponding qmake-statement in build() accordingly.
+ 'qt5-base'
)
optdepends=()
-makedepends=('git')
+makedepends=(
+ 'coreutils' # for `cut`
+ 'git'
+)
provides=(
"${_pkgname}=${pkgver}"
)
@@ -22,7 +27,12 @@ options=()
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe | awk -F '-' '{print $1"_"$2"+"$3}'
+ _descr="$(git describe --tags)"
+ _ver="$(printf '%s' "${_descr}" | cut -d '-' -f 1,2 | tr '-' '_')"
+ _rev="r$(git rev-list --count HEAD)"
+ _hash="$(printf '%s' "${_descr}" | cut -d '-' -f 3)"
+ _date="$(git log -n 1 --format=tformat:%ci | cut -d ' ' -f 1 | tr -d '-')"
+ printf '%s\n' "${_ver}+${_rev}.${_date}.${_hash}"
}
source=(
@@ -37,13 +47,14 @@ sha256sums=(
build() {
cd "${srcdir}/${_pkgname}"
- qmake-qt4
+ # qmake-qt4 # QT4 or QT5 possible. Change also the dependency accordingly.
+ qmake-qt5
make
}
package() {
cd "${srcdir}/${_pkgname}"
-
+
### I found no way to specify a custom installation directory. So we install manually ...
install -v -D -m755 src/bin/confclerk "${pkgdir}/usr/bin/${_pkgname}"
install -v -D -m644 data/confclerk.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"