summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwebmeister2015-08-11 21:29:51 +0200
committerwebmeister2015-08-11 21:29:51 +0200
commit21b480ba732085bd4c328f4ab6fadfd0f15c445b (patch)
tree781b3db5ed0e4ea3e7d2600df551bfe71a01bf57 /PKGBUILD
parentb37af734edf6d6659d9f0c6645e07009fd110705 (diff)
downloadaur-21b480ba732085bd4c328f4ab6fadfd0f15c445b.tar.gz
Apply patch to fix mhgui
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f149721d3954..f0209f1cf37f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,26 @@
pkgname=congruity
pkgver=18
-pkgrel=2
+pkgrel=3
pkgdesc='A GUI application for programming Logitech(R) Harmony(TM) remote controls.'
arch=('any')
url='http://congruity.sourceforge.net/'
license=('GPL3')
depends=('desktop-file-utils' 'python2-suds' 'python-libconcord>=1.1' 'wxpython2.8')
install="$pkgname.install"
-source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2")
-sha256sums=('16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878')
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ "0001-Fix-mhgui-for-SupportedCapabilities-change-in-web-se.patch")
+sha256sums=('16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878'
+ 'fea8bbb603929afb743beb695de73809e606fa9d24e5810ae34ee72117317245')
package() {
cd "$srcdir/$pkgname-$pkgver"
+
+ msg "Patching..."
+ for i in $srcdir/*.patch; do
+ patch -Np1 -i "$i"
+ done
+
sed -i 's@wxversion.ensureMinimal@wxversion.select@g' congruity mhgui
sed -i 's@#!/usr/bin/env python@#!/usr/bin/env python2@g' congruity mhgui
sed -i 's@#!/usr/bin/python@#!/usr/bin/env python2@g' mhmanager.py