summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorParamvir Likhari2019-01-09 03:39:45 +0530
committerParamvir Likhari2019-01-09 03:39:45 +0530
commit44dc71ff083f3401576b179241868cd275a63e0c (patch)
tree36c1b8d2dcdf6ff09f2ab21255d96766c39574e2 /PKGBUILD
parentf583416ad8db4b87c24efb80b3776e2df395cbe9 (diff)
downloadaur-44dc71ff083f3401576b179241868cd275a63e0c.tar.gz
conky 1.11.2 release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 4 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ac7cb53a7b0..4cebaf240d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Contributer: Paramvir Likhari <plikhari at gmail dot com>
# Maintainer: Paramvir Likhari <plikhari at gmail dot com>
-# This PKGBUILD creates conky for tolua++_5.3 lua + cairo + imlib2 + nvidia
-
-# The git version has built in tolua++_5.3 lua - only supports lua 5.3
+# This conky version has built in tolua++_5.3 lua and only supports lua 5.3
# to create NON NVIDIA package - remove following
# in makedepends 'libxnvctrl'
@@ -24,9 +22,9 @@
# 'perl-xml-libxml' 'perl-xml-sax-expat' in makedepends
pkgname=conky-cairo
-pkgver=1.11.1
+pkgver=1.11.2
pkgrel=1
-pkgdesc='conky - built for nvidia n (tolua++_5.3 in AUR) - conky git has built in lua 5.3 support (tolua++_5.3 NOT required) - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.'
+pkgdesc='conky - built for nvidia - conky now has built in lua 5.3 support (tolua++_5.3 NOT required) - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.'
url='https://github.com/brndnmtthws/conky'
license=('GPL3' 'BSD')
arch=('i686' 'x86_64')
@@ -35,6 +33,7 @@ replaces=('torsmo' 'conky')
conflicts=('conky')
provides=('conky')
+depends=( 'alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'librsvg' 'glib2' 'libxdamage' 'imlib2' 'lua' 'libxnvctrl' 'libxinerama' )
makedepends=( 'cmake' 'git' )
@@ -46,7 +45,6 @@ _myopts=1
case ${_myopts} in
0) ### _myopts=0 for git version #####################################
### we now have tolua++ 5.3 support built in !!!
- depends=( 'alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'librsvg' 'glib2' 'libxdamage' 'imlib2' 'lua' 'libxnvctrl' 'libxinerama' )
_pkgname=conky
@@ -62,8 +60,6 @@ case ${_myopts} in
### NOTE: Install tolua++_5.3 from AUR - one of my other packages besides conkywx weather program
- depends=( 'alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'librsvg' 'glib2' 'libxdamage' 'imlib2' 'lua' 'libxnvctrl' 'libxinerama' 'tolua++_5.3' )
-
_pkgname="conky-${pkgver}"
source=(${url}/archive/v${pkgver}.tar.gz)
@@ -76,21 +72,6 @@ build() {
cd "${srcdir}/${_pkgname}"
-case ${_myopts} in
-1) ### to link to tolua++ 5.3 - See my package tolua++ in AUR #####
- sed -i 's|-Werror||' cmake/ConkyBuildOptions.cmake
-
- sed -i \
- -e 's|\(LUA REQUIRED\) lua5.1 lua-5.1 lua51 lua|\1 lua>=5.3|' \
- -e 's|\(NOT LUA_VERSION VERSION_LESS\) 5.2.0|\1 5.4.0|' \
- cmake/ConkyPlatformChecks.cmake
-
- sed -i \
- -e 's|#include <string>|#include <string>\n#include <functional>|' \
- src/luamm.hh
- ;;
-esac
-
################################################################
cmake \