summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArcher7772015-12-01 19:28:19 +0500
committerArcher7772015-12-01 19:28:19 +0500
commita1e761650b7879c89830bc947525059c00fd47a1 (patch)
tree123eb8d1d11bc4ddf97ad62e81e594bba69b9d8a /PKGBUILD
parentaea871d5ae160f836e3faa0bf703fd9e0f2a0d37 (diff)
downloadaur-a1e761650b7879c89830bc947525059c00fd47a1.tar.gz
1.10.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39b707cfe5c6..771b648eadc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,25 @@
_pkgname=conky
pkgname=conky-cli
-pkgver=1.10.0
-pkgrel=3
+pkgver=1.10.1
+pkgrel=1
pkgdesc="Lightweight system monitor for X, without X11 dependencies"
-url='http://conky.sourceforge.net/'
+url='https://github.com/brndnmtthws/conky'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
provides=('conky')
conflicts=('conky')
-makedepends=('cmake' 'docbook2x' 'docbook-xml' 'docbook-xsl' 'man-db')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db' 'git')
depends=('curl' 'lua' 'wireless_tools' 'libxml2')
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'ascii.patch'
- 'lua53.patch'
- 'ipv6.patch'
- 'curl.patch')
-md5sums=('cdc0298e5f257829d574ae8114170d9b'
- 'd5b765cb7400d2fdca88b6c86aa8eec1'
- '44cdadfe92266e99698e5424b7c6e265'
- '702650dfaaacb4e778f3d3c6a296df0b'
- '8236606ca3d39b9d00a59022d4f953ac')
+ 'lua53.patch')
+
+sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
+ 'a3a74542b6524e5663ad37aaba292b48e8bea3b1')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../ascii.patch # db2x_manxml fails on non-ascii chars
patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
- patch -p1 -i ../ipv6.patch # https://bugs.archlinux.org/task/45626
- patch -p1 -i ../curl.patch # https://github.com/bagder/curl/issues/342
}
build() {