summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArcher7772015-06-30 00:02:00 +0500
committerArcher7772015-06-30 00:02:00 +0500
commitbf7e4336f2c8ed35a3611d2a803c0bccca51726f (patch)
tree0df110bacce69daa3f07111c3d54df9e8bc60b8c /PKGBUILD
parentcf35714c3432092033e28a6768c74e152ee5e3b4 (diff)
downloadaur-bf7e4336f2c8ed35a3611d2a803c0bccca51726f.tar.gz
Updated PKGBUILD acording to official package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0e8de3a9065..81ab5a85714a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,44 @@
-# Maintainer: Archer777 <NAME at gmx dot com>
+# Maintainer: Archer <NAME at gmx dot com>
# Contributor: Army
# Contributor: Dave Reisner <d@falconindy.com>
# Contributor: Karol Cichy <slothck@gmail.com>
+_pkgname=conky
pkgname=conky-cli
pkgver=1.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="Conky command line, without X11 dependencies"
-arch=('i686' 'x86_64')
url="http://conky.sourceforge.net/"
-license=("custom")
+license=('BSD' 'GPL')
+arch=('i686' 'x86_64')
provides=('conky')
conflicts=('conky')
depends=('ncurses' 'wireless_tools')
-source=("http://downloads.sourceforge.net/conky/conky-$pkgver.tar.gz")
+source=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
build() {
- cd "$srcdir/conky-$pkgver"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc --disable-lua --disable-x11 \
- --disable-double-buffer --disable-xdamage --disable-own-window \
- --disable-xft --disable-hddtemp --disable-portmon --enable-wlan
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-lua --disable-x11 \
+ --disable-double-buffer \
+ --disable-xdamage \
+ --disable-own-window \
+ --disable-xft \
+ --disable-hddtemp \
+ --disable-portmon \
+ --enable-wlan \
make
}
package() {
- cd "$srcdir/conky-$pkgver"
-
- make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
+ install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
}
md5sums=('1c8e715a2784d4d799f5fc0213e76d0f')