summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn A Ginis2017-06-05 13:43:31 +0300
committerJohn A Ginis2017-06-05 13:43:31 +0300
commit32847ba7c74bf136945944d4c29752f3c2219b62 (patch)
tree6008edfc5c1ce48158c8699526989924b56cf6c2 /PKGBUILD
parent1a83564f858c992bef4fd61bd38f57c18f152f4b (diff)
downloadaur-32847ba7c74bf136945944d4c29752f3c2219b62.tar.gz
New package commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56d94f2d22c0..f47b6d52917c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=conky-lua-archers-git
_pkgname=conky
pkgver=3166.a58a6d4e
-pkgrel=1
+pkgrel=2
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky/"
@@ -37,9 +37,11 @@ makedepends=(
'perl-xml-sax-expat'
)
source=("git://github.com/brndnmtthws/${_pkgname}.git"
- 'asciime.patch')
+ 'asciime.patch'
+ 'include.patch')
sha1sums=('SKIP'
- 'b07407c2be11cee7bd50e046024b89cf2579c448')
+ 'b07407c2be11cee7bd50e046024b89cf2579c448'
+ '0efe24eab88c48cc1fef0dae001ce935f743c131')
options=('!strip' 'debug')
pkgver() {
@@ -50,11 +52,13 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
+ patch -p1 -i ../include.patch # Build fails with gcc7 due to missing include
mkdir -p build/ # as @afaikifreedom recommended
}
build() {
cd "${srcdir}/${_pkgname}/build"
+
cmake \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \