summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2021-06-29 12:09:20 -0400
committerChris Severance2021-06-29 12:09:20 -0400
commit44b722d50107d808a25613dd047a780939ba2d30 (patch)
treea1310c0237c1359170d969623cbbfab15eb6321f /PKGBUILD
parentefed4a93be818bcfde41f40a2f293b24274fcbc1 (diff)
downloadaur-44b722d50107d808a25613dd047a780939ba2d30.tar.gz
autu: Update to 1.43-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23d304742d0a..9c56f529119f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ _opt_DKMS=1 # This can be toggled between installs
set -u
pkgname='connecttech-cti-serial'
pkgver='1.43'
-pkgrel='2'
+pkgrel='3'
pkgdesc='tty UART driver for BlueStorm BlueHeat Xtreme/104-Plus Titan and Xtreme/104-Express families'
arch=('i686' 'x86_64')
url='http://connecttech.com/product/pci-express-bluestorm-express/'
@@ -32,11 +32,14 @@ source=(
"manual://${_srcdir}.tgz"
#'0000-kernel-4.18-proc_fops-to-proc_show.patch' # https://patchwork.kernel.org/patch/10349751/
'0001-kernel-5.0.0-8250_core-access_ok.patch' # https://lkml.org/lkml/2019/1/4/418
+ '0002-kernel-5.10-async-initialized.patch'
)
md5sums=('52370a65422a372cc2d7c84b4fee230e'
- 'c9f0fc60446b03a66998d90eff031546')
+ 'c9f0fc60446b03a66998d90eff031546'
+ '97cd518024af079d1188398af69ca6cb')
sha256sums=('953d136584f7d1bf276211c0d87e46abc951214a0fba8339db8399cf5f8553fd'
- 'fbb546222486ccbd3fc0cfaf44c146208a27507c20788602fcc6e77853692b00')
+ 'fbb546222486ccbd3fc0cfaf44c146208a27507c20788602fcc6e77853692b00'
+ '3f1c0aec4f287803b0c571ce0258bf16163fed920170fb6eac2ec717f704e3e5')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -86,6 +89,15 @@ prepare() {
# Kernel 5.6
sed -e 's:ioremap_nocache:ioremap:g' -i 'driver/8250_core.c' 'driver/8250_pci.c'
+ # Not compatible with Kernel 4.4 headers
+ #sed -n -e '/^#ifndef __KERNEL__/,/^#endif/ p' "/usr/lib/modules/$(uname -r)/build/include/uapi/linux/tty_flags.h" | sed -e 's:__KERNEL__:ASYNC_INITIALIZED:g' >> 'driver/serial_core_kernel510.h'
+ sed -n -E -e '/ASYNCB_INITIALIZED|ASYNCB_SUSPENDED|ASYNCB_CTS_FLOW|ASYNCB_CHECK_CD|ASYNCB_NORMAL_ACTIVE|ASYNCB_CLOSING/ p' "/usr/lib/modules/$(uname -r)/build/include/uapi/linux/tty_flags.h" >> 'driver/serial_core_kernel510.h'
+ #cp -pr 'driver' 'driver.orig'; false
+ #diff -pNau5 'driver'{.orig,} > '0002-kernel-5.10-async-initialized.patch'
+ patch -Nbup0 -i "${srcdir}/0002-kernel-5.10-async-initialized.patch"
+ sed -e '/ArchLinuxPatch-0002-Begin/ r driver/serial_core_kernel510.h' -i 'driver/serial_core.c' 'driver/8250_core.c'
+ rm 'driver/serial_core_kernel510.h'
+
pushd 'driver' > /dev/null
# Fix permissions
find -type 'f' -perm '/111' -exec chmod 644 '{}' '+'